Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Backwards compatibility between CoDeSys service packs ???

Michael
2005-04-04
2005-04-15
  • Michael

    Michael - 2005-04-04

    Hi,

    We have been using CoDeSys 2.3.1.4. I started looking at later service packs but have noticed a few issues (won't go into detail just yet). What is the offical stance on backwards compatibility ? I had a look on the website but could not find any information regarding this.

    Thanks,

    Michael.

     
  • RolandWagner

    RolandWagner - 2005-04-07

    Of course new versions of CoDeSys are backward compatible, so you can program your controller with the most recent version 2.3.4.1.

    In the Customer Download Area on the 3S-Website you can download the Bug Report. Sometimes new versions or service packs caused problems because customers used fixed bugs as features . In case you work with the normal features there should not be any problem.

     
  • Anonymous - 2005-04-08

    Originally created by: Gast

    I did try looking for the bug fix list when the new service pack was released but couldn't find it. Is this in protected download area ?

    The problems I've experianced are basic things like the project simply not loading into the CoDeSys editor. I had not expected this to be a problem between minor version releases. As I was looking at newer versions, the installation of CoDeSys on my computer was more recent than my collegues.

    I'll try to be brief.

    We have been using version 2.3.1.4. This is the version all my collegues are using.

    If I edit a project in version 2.3.3.6 then one of my collegues edits the same project in 2.3.1.4 that project then becomes corrupted.

    Same test but with version 2.3.4.1. If I edit the project in the new version the project can no longer be opened by version 2.3.1.4. Attempts to do so cause a MS Visual C++ runtime library error "Assertion failed". Screen shot attached.

    Is this something that should work or is this unsupported ?

    Thanks,

    Michael.

    IMG: codesys error.jpg

     
  • RolandWagner

    RolandWagner - 2005-04-08

    You can find the the bug fix list within the customer download area under http://www.3s-software.com/index.shtml?Down2 . In case you do not have the right passwort available please contact us under e demo@3s-software.com e .

    The problem you describe is a real bug. I already passed it on to the 3S support hotline.

     
  • Michael

    Michael - 2005-04-15

    Hi Roland,

    Is this bug likely to be fixed in another service pack for CoDeSys 2.3 or are we limited to using version 2.3.1.4 ?

    Thanks,

    Michael.

     

Log in to post a comment.