ProfiNET-Master unter Raspbian Buster

Deutsch
akneer
2019-08-08
2019-09-13
  • akneer

    akneer - 2019-08-08

    Hallo,

    Ich versuche gerade oben gennantes Szenario ohne Erfolg.
    https://forum.codesys.com/viewtopic.php?f=23&t=6247&start=15#p16870
    läuft leider so auch nicht.

    PN-Controller ist fehlerfrei, jedoch wird kein Slave grün.
    Beim Scannen von Teilnehmern ist auch keiner aufgelistet.

    Jemand noch ne Idee ?

    Hardware:
    Raspberry PI 3B+
    Codesys Runtime 3.5.15.0

     
  • akneer

    akneer - 2019-08-29

    Hab es inzwischen mit einer USB-Ethernet Erweiterung getestet.
    Mit "eth1" funktioniert alles korrekt.
    Stell ich es aber wieder auf "eth0" ist keine Verbindung zu den Slaves vorhanden.

    zusätzlich getestet mit
    Codesys Runtime 3.5.11.20

     
  • eschwellinger

    eschwellinger - 2019-08-30

    Ist halt sicher in RASBIAN Buster, Vlan tag was auch immer ich checks mal, dauert aber noch.
    Grüsse
    Edwin

     
  • akneer

    akneer - 2019-09-13

    Hallo Edwin,

    Denke ich hab den Fehler gefunden.

    Durch zuweisen einer festen IP in der Taskleiste fehlen dem PI noch weitere Einstellungen wie Subnetz und Gateway.

    Wurde über sudo nano /etc/dhcpcd.conf eingestellt und siehe da es läuft.

    Versteh aber noch nicht, wieso es mit dem USB Adapter funktioniert hat

     
  • eschwellinger

    eschwellinger - 2019-09-13

    Hi,
    du könnest das auch CODESYS machen lassen,
    den Haken am NetzwerkAdapter(in CODESYS Gerätebaum) setzen und in /etc/CODESYSControl_User.cfg
    noch eintragen für welchen Adapter du das erlaubst(aus CODESYS heraus die IP zu setzen)

    [SysSocket]
    Adapter.0.Name="eth1"
    Adapter.0.EnableSetIpAndMask=1

    Grüße
    Edwin

     

Log in to post a comment.