Codesys V2.3 SP3 fehlende Bibliotheke

Deutsch
abhaem
2018-11-05
2018-11-12
  • abhaem

    abhaem - 2018-11-05

    Hallo zusammen,
    ich bin neu in diesem gebiet mit Codesys, habe mehr mit Siemens S7 und Tia Portal programiert.
    Nun muss ich was mit Codesys V2.3 SP3 machen. Ich habe da ein vorhandenes Programm und will dies
    öffnen und ändern. Leider fehlt mir da eine Bibliotheke von ( Festo_Motion.lib 17.6.09 06:10:48 ) habe schon einiges probiert,
    aber Codesys verweist immer wieder auf die Datei. Eine neuere Datei nimmt Codesys auch nicht an.

    Ich hoffe es kann mir dabei jemand weiterhelfen, das ich das Programm geöffnet bekomme.
    Andreas

     
  • Pitsch

    Pitsch - 2018-11-07

    Hallo

    Die Version 2.3.... ist natürlich veraltet. Ich weiss nicht ob Du da noch Bibliotheken bekommst dazu. Werden sicher noch eineige vorhanden sein. Doch ob deine benötigte Funktion dabei ist, ist sicher fraglich.
    Doch wenn Du weisst, was diese aufgerufene Funktion macht, oder machen sollte, kannst Du sie ja selber programmieren. Den eine Bibliothek, besteht in den meisten Fällen nur aus einer Sammlung solcher Funktionen. Die vielfach auch noch Funktionen innerhalb der Bibliothek benötigen und aufrufen.
    Du musst natürlich nicht eine ganze Bibliothek programmieren. Nur diesen einen benötigten Funktionsblock oder Funktion. Den Aufruf in deinem Programm muss natülich auch angepasst werden. Und ganz wichtig, deine Steuerung muss die Version 2.3... auch noch akzeptieren. Wenn die Steuerung für Version 3... Konzipiert ist, weiss ich nicht, ob Du da noch Version 2... Programme hochladen kannst.

    Mit freundlichen Grüssen! Pitsch

     
  • RolandWagner

    RolandWagner - 2018-11-07

    Nachdem das eine Festo-Bibliothek ist, die Dir fehlt, solltest Du am Besten bei Festo nachfragen.

     
  • abhaem

    abhaem - 2018-11-07

    Roland Wagner hat geschrieben:
    Nachdem das eine Festo-Bibliothek ist, die Dir fehlt, solltest Du am Besten bei Festo nachfragen.

    Das habe ich auch schon Versucht, bei Festo etwas zu bekommen. Dann sagt mir das Programm, die Datei hat sich geändert,und ist neuer, und das Programm wird doch nicht geöffnet.

     
  • Pitsch

    Pitsch - 2018-11-12

    Hallo abhaem

    So wie ich das sehe, könnte die Bibliothek, mit einer neueren geupdateten Version von CodeSys ertellt wooden sein. Und die scheint nicht rückwärts kompatibel zu sein.
    Was Du machen könntest, bei WAGO fragen, ob Du die neueste Version von CodeSys bekommst. Wenn Du das Programm mal dort erworben hast, ist das in der Regel kostenfrei.
    Dann öffnest Du das Programm, mit dieser Version. Möglicherweise fünktioniert es so.
    Wenn das nicht hilft, musst Du die entsprechenden Funktionen nach möglichkeit doch selber Programmieren. Da bin ich auch am Ende meiner Weissheit.

    Mit freundlichen Grüssen! Pitsch

     

Log in to post a comment.