Raspberry Pi 3b+ Profinet connection problem

FloHmn
2019-11-07
2019-11-14
  • FloHmn

    FloHmn - 2019-11-07

    Hi

    I try to run a Raspberry Pi 3b+ on Raspbian stretch as Profinet Master to communicate with a SEW MDX61B with DFE32B Module. I have set up the PN-Controller as you can see in the screenshot and have added the MDX61B with the latest GSDML-file by SEW.
    When I set the Pi to "run" the PN-controller is fine, but the MDX61B says "DCP no RealStationName" and i wont get any connection.

    I have checked the Profinet-Name and IP of the MDX by using SEW Movitools and by running a network check in SIEMENS STEP7. Both can find the MDX under its name and address. So I think some of my codesys settings are wrong.

    I hope you can help me soon.

    Florian

    PS: Please answer in german or english.

    IMG: 2019

    IMG: 2019

    IMG: 2019

    IMG: 2019

    IMG: 2019

    IMG: 2019

     
  • eschwellinger

    eschwellinger - 2019-11-08

    Hi,
    did you activate:

    l viewtopic.php?f=23&t=6247&p=16870#p16870 l

    Using VLAN-Tags Need to be enabled:

    sudo apt install vlan # install VLAN-Packet
    sudo modprobe 8021q # load 8021q Kernelmodul

    BR
    Edwin

     
  • FloHmn

    FloHmn - 2019-11-08

    Hi
    Thank you for the advice.

    I have already tried to enable vlan.
    The installation worked fine, but the loading of the Kernelmodule didn't responds any statement. Is this correct?

    BR
    Florian

    Edit: I found my mistake. The Comand you have to put into the "/etc/modules" ist just the module Name "8021q"

     
  • FloHmn

    FloHmn - 2019-11-14

    Hi again

    I have an other problem now.
    The Bus is working but I won't get any data from the Frequency-Inverter.

    Do I have to read the data by any Comand or sth.? I thought the data would be updated cyclic in my Variable-List.

    Hope you can help me again.

    BR
    Florian

    IMG: 2019

     
  • i-campbell

    i-campbell - 2019-11-14

    Variables need to be in a task to update. Change "Variablen aktualisiert" in the bottom right hand corner to "always in bus cycle". Then pick the bus cycle in the properties for the master device.

    Almost there!

     

Log in to post a comment.