codesys API for compiler and visualisation versions upgrade

lyn
2012-05-18
2013-05-03
  • lyn

    lyn - 2012-05-18

    Hi,

    I have explored the CoDeSys API and help file. Also we have used Python introspection on the various interfaces/objects of projects, project, library manager to no avail.

    I am trying to find API to upgrade/invoke the following:

    1. Visualization Profile Version
    2. Compiler version
    3. Visualization Style Version
    4. Build the Project

    Any help would be much appreciated.

     
  • Anonymous - 2012-05-18

    Originally created by: M.Schaber

    Hi, lyn,

    lyn hat geschrieben:
    I am trying to find API to upgrade/invoke the following:
    1. Visualization Profile Version
    2. Compiler version
    3. Visualization Style Version

    Currently, there's no ScriptEngine API available to set those versions.

    You may use your support contact to raise this as an "Requirement" issue in our support database.

    lyn hat geschrieben:
    4. Build the Project

    Building of the project is currently only implicitly triggered when a login to the device is done. Explicit access to the build commands is currently planned for V3.5 SP2 (Issue CDS-22407). You may use your support contact to add your company as an interested customer in this issue.

    HTH,
    Markus Schaber

     
  • lyn

    lyn - 2012-05-18

    Hi Markus,

    Thanks for quick reply.

    when V3.5 SP2 is going to release ?

    Thanks ,
    Lyn

     
  • Anonymous - 2012-05-18

    Originally created by: M.Schaber

    Hi, Lyn,

    lyn hat geschrieben:
    when V3.5 SP2 is going to release ?

    We're just finishing the Release of V3.5 SP1 those days. V3.5 SP2 is currently for December 6th.

    HTH,
    Markus

     
  • sms

    sms - 2013-02-22

    Hello Markus,

    Do we have any update as to whether the Build Project API has been incorporated?

    Thanks.

     
  • Anonymous - 2013-02-22

    Originally created by: M.Schaber

    Hi,

    The improvement was incorporated into V3.5 SP2:

    Project objects were extended with the following members:

    Object objects are now extended with the following members:

    Objects which are Applications now extended with the following members:

    Users can use the system.get_messages(Guid) and system3.get_message_objects(Guid, Severity) calls to check whether any errors or other compile messages were added.

    To help the users to find the appropriate messages, system.get_message_categories() and system.get_message_category_description() were added, so they can print all message categories and their guids.

     
  • sms

    sms - 2013-04-09

    Thanks Markus. This is really useful info.

     
  • Anonymous - 2013-04-30

    Originally created by: M.Schaber

    Hi,

    If you're still reading: Could you describe the exact use case?

    Would the possibility to allow an upgrade of those elements to the newest version (in analogy to the "Project Environment" dialog) be enough? (This is already filed as an improvement in our jira database: CDS-34105

    Or do you really need to explicitly set those versions to arbitrary values via scripting?

    Thanks,
    Markus

     
  • sms

    sms - 2013-05-03

    Yes. The requirement is to upgrade to the newest compatible version via scripting. i.e. set the versions to the newest version/some specific version so that manual upgradation of the versions of tons of project is avoided and can be done easily via. scripting.

    Best.

     
  • Anonymous - 2013-05-03

    Originally created by: M.Schaber

    Hi,

    The aforementioned CDS-34105 improvement will allow to upgrade to the newest version during project load, but not to a specific version.

    Is the possibility to set a specific version really important? And what is the use case?

    Thanks, Markus

     

Log in to post a comment.