DocScripting - libdoc.exe error

SMF1
2019-07-25
2019-09-11
  • SMF1

    SMF1 - 2019-07-25

    Hello,

    can anyone help me with this error I get when calling "libdoc generate"?

    As described in the documentation I set the environment variables:
    LIBDOC_CODESYS -> set to "C:\Program Files (x86)\3S CODESYS\CODESYS\Common\CODESYS.exe" --Profile="CODESYS V3.5 SP11"
    PATH -> added C:\Program Files (x86)\3S CODESYS\CODESYS\DocScripting\3.5.11.0

    Step 1:

    C:\my_Libs\SYS\trunk\output>libdoc export
    CODESYS LibDoc Scripting Collection V3.5.11.0
    Export <lib> to <content> using <codesys>
    <lib> = C:\my_Libs\SYS\trunk\output\sysLib.library
    <content> = C:\my_Libs\SYS\trunk\output\sysLib.json
    <codesys> = "C:\Program Files (x86)\3S CODESYS\CODESYS\Common\CODESYS.exe" --Profile="CODESYS V3.5 SP11"
    calling: "C:\Program Files (x86)\3S CODESYS\CODESYS\Common\CODESYS.exe" --Profile="CODESYS V3.5 SP11" --noUI --skipunlicensedplugins --docexport="C:\my_Libs\SYS\trunk\output\sysLib.library|C:\my_Libs\SYS\trunk\output\sysLib.json"
    ...
    DocExport: Loading project C:\my_Libs\SYS\trunk\output\sysLib.library...Project loaded in 04.06 sec.
    DocExport: Build...
    Übersetzen: Text: C0: ------ Übersetzungslauf gestartet: Applikation:  -------
    Übersetzen: Text: C0: Code typisieren ...
    Übersetzen: Text: SA0: Zusätzliche Codeprüfungen ...
    Übersetzen: Text: SA0: Zusätzliche Codeprüfungen abgeschlossen -- 0 Fehler
    Übersetzen: Text: C0: Kompilierung abgeschlossen -- 0 Fehler, 0 Warnungen
    Compile done in 01.05 sec.
    DocExport: Processing... Done.
    DocExport: Closing project... Done.
    Exported in 00.27 sec.
    Result: 0 -- Done!
    

    Step 2:

    C:\my_Libs\SYS\trunk\output>libdoc generate sysLib.json Frame
    CODESYS LibDoc Scripting Collection V3.5.11.0
    Generate: C:\my_Libs\SYS\trunk\output\conf.py
    Generate: C:\my_Libs\SYS\trunk\output\libdoc_builder.py
    Generate: Frame\info.rst
    Generate: Frame\libraries.rst
    Generate: Frame\index.rst
    Traceback (most recent call last):
      File "<string>", line 139, in <module>
      File "<string>", line 133, in main
      File "C:\Jenkins\workspace\3.5.11.x\BUILD_V3.5.11.x_LibDoc\LibDoc\build\libdoc\out00-PYZ.pyz\libdoc.generate", line 167, in generate
      File "C:\Jenkins\workspace\3.5.11.x\BUILD_V3.5.11.x_LibDoc\LibDoc\build\libdoc\out00-PYZ.pyz\jinja2.environment", line 989, in render
      File "C:\Jenkins\workspace\3.5.11.x\BUILD_V3.5.11.x_LibDoc\LibDoc\build\libdoc\out00-PYZ.pyz\jinja2.environment", line 754, in handle_exception
      File "C:\PROGRA~2\3SCODE~1\CODESYS\DOCSCR~1\3511~1.0\templates\index.rst", line 6, in top-level template code
        {% set toc = particle.toc %}
      File "C:\Jenkins\workspace\3.5.11.x\BUILD_V3.5.11.x_LibDoc\LibDoc\build\libdoc\out00-PYZ.pyz\jinja2.environment", line 408, in getattr
      File "C:\Jenkins\workspace\3.5.11.x\BUILD_V3.5.11.x_LibDoc\LibDoc\build\libdoc\out00-PYZ.pyz\libdoc.content", line 813, in toc
      File "C:\Jenkins\workspace\3.5.11.x\BUILD_V3.5.11.x_LibDoc\LibDoc\build\libdoc\out00-PYZ.pyz\libdoc.content", line 188, in children
    IndexError: list index out of range
    

    I think there is something wrong with the settings. Maybe there is another environment variable to be set?
    I wonder about the directory "C:\Jenkins\workspace\". There is no such directory on my PC.

    Although I have read that I do not need to install additional software I installed finally Python (and added the installation path to PATH), and also installed the HTML Help Workshop. But this doesn't help either.

    Thanks for any idea to resolve this error.

     
  • SMF1

    SMF1 - 2019-08-13

    Tested also with DocScripting 3.5.14.0 but same behaviour!

     
  • John Doe 67

    John Doe 67 - 2019-09-11

    Hello SMF1,

    I've a (maybe stupid) question.
    You wrote:
    ...I set the environment variables:
    LIBDOC_CODESYS -> set to "C:\Program Files (x86)\3S CODESYS\CODESYS\Common\CODESYS.exe" --Profile="CODESYS V3.5 SP11"
    PATH -> added C:\Program Files (x86)\3S CODESYS\CODESYS\DocScripting\3.5.11.0

    Where did you set theses varaiables?

    Best regards
    JohnDoe

     

Log in to post a comment.