Connection fainted when start Codyses Runtime RTE

gerwinvdw
2020-05-26
2020-05-28
  • gerwinvdw

    gerwinvdw - 2020-05-26

    Hello fellow Codesys users,

    I am trying to get a Codesys project running on a SoftPLC with RTE runtime V3 x64. I already have it running on a SL runtime from Codesys, but because of the irrugaler cycletimes I want to try it on RTE.

    I can find the RTE runtime and download a program in to it, but when I want to start the program the connection faint and the runtime is not findable anymore. In the PLC configuration I can see that the program is downloaded.

    Can anybody help me with this problem.

    Thanks a lot!

     

    Last edit: gerwinvdw 2020-05-26
  • eschwellinger

    eschwellinger - 2020-05-26

    Hi,
    which version is this on which Windows version?
    which CPU is in your device?
    You need to check ( by google) how many real CPU cores it has.
    Check if numproc does fit to that.

    BR
    Edwin

     
  • gerwinvdw

    gerwinvdw - 2020-05-26

    Codesys version: Codesys V3.5 Sp15 Patch 3 (64 bit)
    Windows version: Windows 10 LTSC (64 bit)
    Runtime version: Codesys control RTE V3.5.16.0
    CPU: i5-5300U (2 cores)

     

    Last edit: gerwinvdw 2020-05-26
  • stanvo

    stanvo - 2020-05-27

    Hello, i'm a coworker of Gerwinvdw,

    We tried some things but at the moment we can't access the PLC, we updated our program device to SP16 to match the runtime version. Also we checked the BIOS settings etc etc. We can ping the other SoftPLC but when we scan network we can't find the runtime control RTE running on that PC. We installed the Codesys EtherExpress driver (CmpEt1000MPD). We also selected this in the component manager of the runtime control see attachments. Still we can't scan the device, maybe we missed something?

     
  • eschwellinger

    eschwellinger - 2020-05-27

    Hi,

    since SP16 the config files are splitted in CODESYSControl.cfg and CODESYSCOntrol_User.cfg

    this is somehow not correct in your attached config file-- ( this component section should be in CODESYSControl_user.cfg)

    Just uninstall CODESYS RTE and remove all existing files in C:\ProgramData\CODESYS\CODESYSControlRTEV3
    Then reinstall it - I'm pretty sure then it will work.

    BR
    Edwin

     
  • stanvo

    stanvo - 2020-05-28

    Hello,

    Thanks for this info, we can now load the program but when we start the runtime PLC, the connection is gone. We also can't ping the PC where the PLC is running on anymore. We installed Codesys Development program on that PC and so we can load the program, and get online. Unfortunately this is not what we want to do. Our softPLC (PC where the PLC is running on) should be programmed from the programmers laptop.

    Is it possible that we should change some settings in the "Remote PLC" from the RTE runtime? Or should we change settings in the config files?

     
  • stanvo

    stanvo - 2020-05-28

    SOLVED

    We had an EtherCAT master in our project, when we started our runtime RTE he uses that port for his communication. When we deleted the EtherCAT master it all works fine. This means that we need an extra ethernet port to program the device so the other one can be used for EtherCAT communication.

     

Log in to post a comment.