Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Ethercat IO-Link master process data offset

rmaas
2021-10-08
2021-10-11
  • rmaas

    rmaas - 2021-10-08

    Hello all,

    I am trying to get the following IO-Link master from Beckhoff to work with a Codesys controller.

    Beckhoff EP6228-0042

    Everything is working fine i have added the latest xml description file from the Beckhoff website and the ethercat master and IO-Link master are not reporting any errors.

    The problem is when i add io-link devices the process data is not showing.
    I have contacted Beckhoff but they say it should work with Twincat and they cannot help me with Codesys.

    After some troubleshooting and testing i found out that the Process data is shifted 32bits.

    (see attached screenshots)
    When the IO-Link Gateway IEC Object variable m_wInOffset is changed from 0 to 32 everything is working fine and all process data is updated at the right adress.

    So i thought problem solved, but...

    How can to make this change permanent?

    I can not write this variable from the program, if i try i get an error that the variable is no input of EP6228_0042_Gateway...

    Does anyone have an idea how to make this change in process data offset permanent?

    Best Regards,
    Rinie

     
  • eschwellinger

    eschwellinger - 2021-10-08

    which version exactly are you using?

     
    • rmaas

      rmaas - 2021-10-08

      this is 3.5.16.4, also tried with 3.5.17.0 and raspberrypi based controller, same problem occurs.

       
  • eschwellinger

    eschwellinger - 2021-10-09

    I would use 3.5.17.10 and latest Ethercat Package ( updated by the CODESYS Installer) - check if 4.x.x.x Ethercat package is in your project.

     
    πŸ‘
    1

    Last edit: eschwellinger 2021-10-09
    • rmaas

      rmaas - 2021-10-11

      After updating the codesys ethercat package to 4.2.0.0 the process data is working again without having to set any offset!

      Thanks a lot for pointing to this solution!

      BR,
      Rinie

       

Log in to post a comment.