Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Raspberry PI profinet slave not reachable at TIA Portal

adisz
2020-04-24
2021-04-21
  • adisz

    adisz - 2020-04-24

    Hello, I did everything as described at https://forge.codesys.com/forge/talk/Runtime/thread/04361f89ec/?limit=25#718f
    Also generated gsd file, and imported it at TIA portal (s7-1200). But plc doesn't see RPI device (not reachable), but it's available when I try to assign profinet name (also not possible). Tried to change name to default, but I think it doesn't matter. Could someone tell me what is wrong?
    Screens attached.

    edit: it seems that there is something missing at the post from link above regarding to do with rpi 3b+ which I am using.

     

    Last edit: adisz 2020-04-24
  • adisz

    adisz - 2020-04-24

    Thanks, it's good to know there is a good manual for this. I couldn't find it before. I just managed to solve the problem. In my case, it was probably an old version of the runtime, but I made many attempts and changes, so it could be something else. Anyway, thank you for the answer, it may be useful to others if they have such a problem.

     
  • toernblom

    toernblom - 2021-04-20

    Hello, what steps did you take to generate the GSD file?
    Thanks,

    • Anton
     
    • adisz

      adisz - 2021-04-20

      That was a year ago, so I don't remember the details, but please check this from "Tools" menu

       
  • toernblom

    toernblom - 2021-04-21

    Haha you remembered correctly! Thanks alot, that really helped 😁

     

    Last edit: toernblom 2021-04-21

Log in to post a comment.