Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

RP4 Codesys not running after update

  • celliott - 2021-12-09

    I'm having great difficulty getting Codesys to run following the execution of the following RP update commands:
    sudo apt-get update
    sudo apt-get upgrade -y
    sudo apt-get dist-upgrade
    sudo rpi-update
    sudo reboot

    The update process was completed without error and I've always used these commands to update/upgrade.

    When I execute the command "sudo /etc/init.d/codesyscontrol stop" I get the following response:
    codesyscontrol not running

    When I execute the command "sudo /etc/init.d/codesyscontrol start" I get the following response:
    License backup created
    cat: /sys/devices/virtual/bcm2708_vcio/vcio/dev: No such file or directory
    mknod: missing operand after β€˜c’
    Special files require major and minor device numbers.
    Try 'mknod --help' for more information.
    codesyscontrol started

    Package Info via Codesys gives the following response:
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Architecture Description
    ii codesyscontrol armhf codesyscontrol based on SDK , from Tue Mar 2 13:34:38 CET 2021 [127], Release build

    Runtime Info via Codesys gives the following response:
    ; <enable>1</enable>
    ; <type>normal</type>
    ; <timestamp>rtc</timestamp>
    ; <deactivatable>0</deactivatable>
    ; <dump>always</dump>
    ; <filter>0x0000000f<filter>
    ; <maxentries>1000</maxentries>
    ; <maxfiles>1</maxfiles>
    ; <maxfilesize>1000000</maxfilesize>
    ;Timestamp, CmpId, ClassId, ErrorId, InfoId, InfoText
    ;ClassId: LOG_INFO =1
    ;ClassId: LOG_WARNING =2
    ;ClassId: LOG_ERROR =4
    ;ClassId: LOG_EXCEPTION =8
    ;ClassId: LOG_DEBUG =16
    ;ClassId: LOG_PRINTF =32
    ;ClassId: LOG_COM =64

    So I have a RPI 4 with 8GB RAM, running V4.0.1.0 with multicore license and development V3.5.17.10

    I tried removing and reinstalling V4.0.1.0 a few times without success.

    How do I get Codesys to run and is there any more information you need to further assist?

  • eschwellinger

    eschwellinger - 2021-12-10

    I would do a clean fresh install not a dist-update.
    Then if you are on SP17 use the CODESYS unstaller to update to or latest runtime version

  • chris18 - 2022-02-04

    Same problem here.
    Did the fresh install help?

  • eschwellinger

    eschwellinger - 2022-02-04

    since Bullseye update from 28.1 even this will not work anymore.

  • celliott - 2022-02-04

    Yes this fixed the problem and running smoothly ever since.

  • chris18 - 2022-02-05

    Thank you very much for the hints.
    I now use Debain 9 ("Stretch") and it seems to run fine.
    LS, Christoph

  • vand3000 - 2022-02-14

    I had the same issue with runtime :
    ii codesyscontrol armhf codesyscontrol based on SDK , from Fri Aug 27 12:04:56 CEST 2021 [121], Release build

    sudo rpi-update e1050e94821a70b2e4c72b318d6c6c968552e9a2

  • eschwellinger

    eschwellinger - 2022-02-14

    This problem will be solved with release end of February (24th)


    Last edit: eschwellinger 2022-02-14
    • mauda - 2022-02-22

      Hi eschwellinger,

      I have the same problem with my runtime. I am using the Kernel-Version 5.10.92 and Raspian Bullseye (Release 11).

      When on the 24th February the release will be available?

      Thank you in advance!

  • FPawlak - 2022-02-25

    Hi. It's after 24.02.2022 and I don't see new version.
    Do you know when it will be finally aviable?

  • eschwellinger

    eschwellinger - 2022-02-25

    sorry for the delay seems to be planned for start of next week.

    • fajean - 2022-03-12

      I am trying to get CODESYS to run on a freshly-installed RPi (Linux raspberrypi 5.10.103-v8+), with package version, and the service is not starting.

      The executable is not execution, the log file says "file not found". The file that the RPi is trying to launch IS physically present (I can "cat" its contents), but it seems like it is an invalid executable.

      Is it possible actually does not solve the issue?

  • eschwellinger

    eschwellinger - 2022-03-12

    Sounds like you try to install the packagage on a 64bit Bullseye? You need a 32bit OS.

    • fajean - 2022-03-12

      Thanks! The OS was installed by a colleague, and I did not even realize (a) there was a 64-bit version now and (b) it was not compatible with CODESYS.

    • fajean - 2022-03-14

      Just as a confirmation that the error in the OS installed was indeed the (only) problem, I was able to install and start CODESYS on the RPi after a reinstall of the 32-bit OS.


Log in to post a comment.