Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

conflict between raspberry time and 4100 version ?

  • phenixrb

    phenixrb - 2021-06-25

    Hello everyone ,
    I updated to version 4100 and since I see a fault in the GPIOs of the raspberry:
    I am using a raspberry GPIO to pulse to an external hardware watchdog.
    the pulse is managed directly by raspbian:

    import RPi.GPIO as GPIO
    import time
    PULWD = 16 # BCM / GPIO
    GPIO.setwarnings (False)

    GPIO.setmode (GPIO.BCM)
    GPIO.setup (PULWD, GPIO.OUT)

    while True:
    GPIO.output (PULWD, 0)
    time.sleep (0.5)
    GPIO.output (PULWD, 1)
    time.sleep (0.5)

    so far this has always worked with all other versions of codesys.
    since the update, as soon as my codesys program is in RUN on the raspberry, the GPIO signal is completely random.
    when the program is in STOP, the GPIO signal flashes again normally ....
    I am not using any raspberry GPIO in the codesys program.

    Thanks for your help.

  • phenixrb

    phenixrb - 2021-06-26

    Hello everyone,
    if it helps:
    not using GPIOs_A_B, I disabled it in the program and that solved my problem.
    although GPIOs appear as "not used", it seems that this is not taken into account well in codesys.

    this remains a problem for those who want to use GPIOs_A_B


    Last edit: phenixrb 2021-06-26
  • Ingo

    Ingo - 2021-07-01

    Thanks a lot for this report, and even tracking down the problem this far. I appreciate this!

  • i-campbell

    i-campbell - 2021-07-01

    which Raspberry Pi Model do you use? For anything newer than the Pi B, meaning Pi2, pi3, pi4 or PiB+, you should be using the other device description. (Right click the gpio, update device, select the device description "GPIOs B+/Pi2")

  • phenixrb

    phenixrb - 2021-07-01

    You're welcome ingo, it seems to me that's the purpose of this forum, some helped me when I was stuck, so if I can save others from spending hours looking for solutions.
    it would be nice if codesys looked at the problem too....
    otherwise, I use a raspberry pi4, and the device is updated on "GPIOs B + / Pi2" as in the picture.


Log in to post a comment.