Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Ethernet over EtherCAT

Anonymous
2019-04-15
2021-09-22
  • Anonymous - 2019-04-15

    Originally created by: OW_RPi

    Hi,

    is RPi3 an EoE capable device?
    How to setup EoE correctly in CODESYS?
    IP routing needed?
    Please help!

    Best regards,
    Oleg

     
  • eschwellinger

    eschwellinger - 2019-04-15

    Hi,
    yes, you need to setup the following steps under Linux:

    set up tap0 device - on a Linux system with tuntap support this looks somehow like this:

    Example:
    /sbin/ip tuntap add tap0 mode tap
    /sbin/ip link set tap0 up
    /sbin/ip addr add 192.168.2.1/24 dev tap0

    BR
    Edwin

     
  • Anonymous - 2019-04-17

    Originally created by: OW_RPi

    Hello Edwin,

    thank you for your quick reply.
    I managed to handle EoE with your helpful hints

    However, it seems to be very complicated:
    - manage IP routing on RPi
    - manage IP routing on Engineering PC
    - All tap and IP route settings on RPi are gone after a restart of Codesys runtime or system reboot. Is there a possibility to make these settings persistent?
    - I am able to ping my EoE device from my Engineering PC. However, it is not possible to use the device's engineering tool on my PC. Timeouts and 'Device is busy' messages are the reasons. Any ideas?

    Thank you!
    Best regards,
    Oleg

     
  • erikattolini

    erikattolini - 2020-12-01

    Hi,
    i have some problems with EoE on EtherCAt devices on linux x64 runtime,
    I have configured tap0 and Eoe devices,The first device responds to the ping request but all ather not.
    if I remove the EoE configuration of the first node, the second responds but the subsequent ones continue not to respond.

    what could be the reason??

    Best regards
    Erik Attolini
    [img src=attachment.png width=50%
    ]

     
  • eschwellinger

    eschwellinger - 2020-12-02

    Which versions are involved?

     
    • erikattolini

      erikattolini - 2020-12-04

      Hi,
      version codesys Enginering and runtime are 3.5.16.20.
      But i have same problem also with older versions

       
  • eschwellinger

    eschwellinger - 2020-12-04

    which drives are you using, there is a known problem with CT drives..

     
    • erikattolini

      erikattolini - 2020-12-04

      Hi,
      i'm using Controltechniques drive M700 and Digitax HD(M753),other drives in pictures dosn't support EOE.

       
  • eschwellinger

    eschwellinger - 2020-12-04

    This is a problem in the slaves ethercat stack of the CT drives,
    as soon you read a non existing object the communication (EoE) stucks.

    There is a workaround available:
    read object 0x1000 from each slave after startup then EoE will work on all drives.
    Additional this need to be reported to CT.

    BR
    Edwin

     
    πŸ‘
    1
    • erikattolini

      erikattolini - 2020-12-07

      Thanks a lot!

       
  • pixsys-nicola

    pixsys-nicola - 2021-09-22

    Hi,
    I need to use EoE, do I need some Routing/Tap etc configuration on the device?

     

Log in to post a comment.