Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Visualization problem Codesys

Runtime
antevante
2016-04-06
2016-04-13
  • antevante

    antevante - 2016-04-06

    Problem with webvisualization in codesys V3.5 sp8.
    I have made a HMI with a row of menu buttons, where each button opens a new page (visualization).
    Some pages contain just a few buttons and I/O fields other pages contain also some pictures in png format and around 100k each and in total around 2mb/page.
    When entering the Web-HMI it take a few seconds to load every page when you open it and then you can switch between the pages without any latency, as long as you keep changing page. If you don’t switch pages for some time, approximately 30-60 seconds, then the pages start to reload the first time again which makes the HMI very slow and annoying to use. Pages with pictures have a much bigger latency than pages with only standard fields. Also when you switch page for the first time after an “idle period” there is latency between mouse click and response from panel button.
    Anyone know if there are any settings to keep the pages in the cache or any other way to solve this problem.
    This is tested with different hardware’s , RaspberryPi, Berghof plc and Codesys softplc with the same result. Web browsers: Chrome and Explorer

     
  • eschwellinger

    eschwellinger - 2016-04-06

    Hi,
    you could give this a try:
    webvisu.cfg.json there is an optional parameter
    „MaxUnusedImageAge“ with Default-Value 20000

    // if an image was not referenced for this time in ms, since it was drawn for the last time,
    // then it will be removed from the cache

    this you could adjust to solve it.

    BR
    Edwin

     
  • Niklas.B

    Niklas.B - 2016-04-12

    Hi Edwin.

    I have the same problem and your solution works fine, but how do I permanent the change in the webvisu.cfg.json file. It gets overwritten every time I do a new download. Tried to change the name to webvisu_my.cfg.json and also tried to write protect the file. Still gets overwritten.
    Is there any other way to fix this problem?

    BR,
    Niklas

     
  • eschwellinger

    eschwellinger - 2016-04-12

    Hi Niklas,

    1. you download your Project with webvisu
    2. Change the json file -> optional Parameter „MaxUnusedImageAge“ with Default-Value 20000
    3. Change the Name in the Webvisu object webvisu to webvisu2 (see screenshot)
      From this point the original webvisu.cfg.json stays untouched because now on every download a webvisu2.cfg.json will be downloaded

    BR
    Edwin

    IMG: Webvisu.jpg

     
  • Niklas.B

    Niklas.B - 2016-04-13

    Hi Edwin.

    It works now.
    Thank you for your help.

    BR
    Niklas

     

Log in to post a comment.