Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Problem installation raspberry package 4.0.1 to 4.1

galexis
2021-06-18
2021-06-29
  • galexis

    galexis - 2021-06-18

    Installation of package for raspberry pi 4.1 faile.
    I have manually installed package edge gateway for linux from store.
    But when I want to install package for raspberry, I have error whith iD and id2 ....what is it ????

    I try to uninstall package 4.01 : error.
    I don't know how to uninstall edge gateway for linux package....

    Help me !!!
    Thank you very much.

     
  • tkjenssen

    tkjenssen - 2021-06-19

    This is clearly a bug in 3.5.17 and/or the raspi package.
    I am running in to this problem and a bunch of others, my whole codesys is crashing and dysfunctional.
    Tried remove/install codesys, did not fix it. Reg cleaner did not work. Next is reinstall of win 10.
    Hope a bug fix its on its way

     
  • eschwellinger

    eschwellinger - 2021-06-21

    Hi,
    please start CODESYS installer- (C:\Program Files (x86)\CODESYS\APInstaller)
    this should lead to an update of the Packagemanagement to version 3.5.17.1

    This will solve the problem then. ( the problem that you are not able to install 4.1.0.0 over 4.0.1.0 version)

     

    Last edit: eschwellinger 2021-06-22
    • phenixrb

      phenixrb - 2021-06-23

      hello ,for me , run codesys installer don't start the update to 3.5.17.1 ??
      I use the 32bits version

       

      Last edit: phenixrb 2021-06-23
  • galexis

    galexis - 2021-06-21

    I haven't got the shortcut "Codesys Installer" ...

     
  • eschwellinger

    eschwellinger - 2021-06-21

    did you install 3.5SP17 complete? Should be part of that. If not installation has failed at least in parts. Would reinstall everything.

     
  • galexis

    galexis - 2021-06-21

    Yes, complete. If I restart installation and choose "Repair" : I haven't got this module in the list

     
  • galexis

    galexis - 2021-06-21

    Were is store .exe of this softwar ? c:/Program Files/CODESYS/.... ?

     
  • aliazzz

    aliazzz - 2021-06-21

    C:\Program Files (x86)\CODESYS\APInstaller

    Or search your machine for APInstaller.GUI.exe

     
  • galexis

    galexis - 2021-06-22

    Ok thank you very much.

     
  • galexis

    galexis - 2021-06-23

    It update only package manager not codesys

     
  • phenixrb

    phenixrb - 2021-06-23

    ok , but how to fix the error installation of raspberry package 4100

     
  • eschwellinger

    eschwellinger - 2021-06-23
    • CODESYS installer...see my post above
     
  • phenixrb

    phenixrb - 2021-06-25

    ok ,thank you , I could update now

     
  • galexis

    galexis - 2021-06-28

    For me library is installerd, but when I want to upgrad raspberry on my project, 4.1 doesn't appear ....

     
  • galexis

    galexis - 2021-06-28

    When I want to desinstall it : codesys crash !!!

     
  • phenixrb

    phenixrb - 2021-06-28

    hello galexis,
    can you show a screen image?
    you say 4.1 is installed, ok, but where?

     
  • galexis

    galexis - 2021-06-28

    On library manager

     
  • phenixrb

    phenixrb - 2021-06-28

    okay,
    this is how I did it:
    download the raspberry 4.1 package in a folder,
    open codesys installer,
    selected "change" in version 3.5.17
    "install files" and choose the downloaded 4.1 package,
    codesys installer installs the package.
    after I find version 4.1 in the codesys runtime package.
    just update the raspberry with version 4.1

     
  • galexis

    galexis - 2021-06-28

    Ok it's more clear for me, but, when I do it: "The package which should be installed are already installed in the target installation". Like I say, package sem to be installed, but not totally because I can't use it, and I can't remove it....

     
  • galexis

    galexis - 2021-06-29

    I have reinstall codesys again: it's ok

     

Log in to post a comment.