realtime kernel and SSH connection

Runtime
boldive
2017-03-09
2017-03-15
  • boldive

    boldive - 2017-03-09

    Hello,
    I did kernel update as described by Edwin
    l viewtopic.php?f=26&t=5652&start=30#p15463 l
    I have tried kernel 4.4.14-bone-rt-r11, tried 4.9.13-bone-rt-r4
    https://www.rcn-ee.com/deb/jessie-armhf/

    also tried 4.4.52-ti-rt-r91
    https://github.com/beagleboard/linux/co ... ertCNelson

    Every time when I update to RT kernel I loose SSH access to BBB.
    In case of problem with SSH, BBB FAQ says:
    Delete the file called "dropbear_rsa_host_key" in the location of /etc/dropbear/.
    Then you need run the command '/etc/init.d/dropbear start'.

    After update to RT kernel directory /etc/dropbear/ does not exist and no command /etc/init.d/dropbear

    Any suggestions how to activate SSH?

    Thanks

     
  • Jimbo200

    Jimbo200 - 2017-03-14

    Hello,
    I have the sampe problem. Have you solved it?

     
  • boldive

    boldive - 2017-03-15

    In Putty choose "Serial" instead of SSH, change COM1 to COM3, leave speed at 9600.
    Open connection and login as root. If invitation doesn't come left-click inside putty window on the cursor and wait 15-30sec.

    If doesn't work, connect monitor, keyboard, mouse to beaglebone and do steps below in terminal. Open terminal and login as root.

    First try to regenerate host keys:

    rm /etc/ssh/ssh_host_*
    dpkg-reconfigure openssh-server
    

    If doesn't help, delete keys,

    rm /etc/ssh/ssh_host_*
    

    Reinstall SSH server. Beaglebone has to see Internet, connect Ethernet cable.

    apt-get install openssh-server
    

    If doesn't work, regenerate keys again:

    rm /etc/ssh/ssh_host_*
    dpkg-reconfigure openssh-server
    

    In my case I have got SSH working. In your case please post the result in this thread.

    https://wiki.debian.org/SSH m

     

Log in to post a comment.