CoDeSys Hangs on BBB update Debian Stretch

Runtime
Anerdgy
2019-07-03
2020-01-30
  • Anerdgy

    Anerdgy - 2019-07-03

    Hi I am using the latest version of CoDeSys 64 3.5.14.30 on a Windows 10 machine.

    Whenever I update the BBB through the runtime deploy tool. It will execute but CoDeSys will stop responding (see attached image) so I have to use task manager to kill the process. The runtime HAS however been deployed. i have tried this on 2 different Win10 machines and 3 different BBB.

    Also for Debian Stretch, root SSH is disabled so one needs to use username debian and password temppwd assuming the defaults are being used.

    IMG: CoDeSys stretch BBB.PNG

     
  • pinf

    pinf - 2019-12-07

    Hi Anerdgy,

    same problem here.

    After serveral Hours the system hangs on randomly. All happens on 6x BBB industrial with codesys licence dongle.

    Here are some Informations:

    Runtime System:
    Linux beaglebone 4.8.17-bone-rt-r2 #1 PREEMPT RT Tue Jan 10 18:43:32 UTC 2017 ar mv7l GNU/Linux

    --> No Problems with Runtime Version 3.5.13.20, runs for months
    --> No Problems with Runtime Version 3.5.13.30, runs for months
    --> Problems with Version 3.5.15.10

    My IDE:

    DETAILED VERSION INFORMATION
    Created at 07.12.2019
    ==============================

    Startup profile: ............................................................... CODESYS V3.5 SP15 Patch 1
    OS version: .................................................................... Microsoft Windows NT 10.0.18362.0
    .NET version: .................................................................. 4.0.30319.42000

    @Support Team: is there any other chance to get this system running stable except rolling back the runtime version?
    We planned to go with BBB enhanced for 1Gbit/s and Ethercat support.

    Thank you and best regards.

     
  • eschwellinger

    eschwellinger - 2019-12-07

    Hi,
    sorry yes,
    you need to update to 3.5.15.20 Version this will solve it.
    BR
    Edwin

     
  • pinf

    pinf - 2019-12-09

    Edwin Schwellinger hat geschrieben:
    Hi,
    sorry yes,
    you need to update to 3.5.15.20 Version this will solve it.
    BR
    Edwin

    Hello Edwin,

    thank you for your fast reply. I'll try it and give feedback at the end of the week!

    best regards
    pinf

     
  • pinf

    pinf - 2020-01-30

    Hi,

    after 4 weeks of 2 shift-use the systems work as usual with Version 3.5.15.20.

    Thank you for the information!

    Greetz

     

Log in to post a comment.