Updated Kernel Now Codesys Exits When Downloading

1 hour ago
  • arj3090

    arj3090 - 2019-09-28

    I updated a BB-400 (based on Pi Compute Module 3+) to the latest RT PREEMPT OS

    4.19.71-rt24-v7+ #1 SMP PREEMPT RT Fri Sep 27 17:22:14 EDT 2019 armv7l GNU/Linux

    Codesys Version

    When I try to download a program to Codesys, it abruptly stops. These are the last few lines of the debug log:

    SysTaskCreate[497]: create BlkDrvUdp(prio:95,interval:0us,stacksize:131072)
    SysTaskFrame[425]:  BlkDrvUdp(tid:3925,OSprio:0) running
    SysTaskCreate[497]: create OPCUAServer(prio:128,interval:0us,stacksize:131072)
    SysTaskFrame[425]:  OPCUAServer(tid:3926,OSprio:0) running
    SysTaskCreate[497]: create CommCycleHook(prio:223,interval:0us,stacksize:131072)
    SysTaskFrame[425]:  CommCycleHook(tid:3927,OSprio:0) running
    ooops... this runtime was built for RASPBERRYPI (-25, 0x00000BB8, 0xFFFFFFFB)
    PlcStartSL[788]: ERROR: Ptrace CONT FAILED (errno 3 No such process)
    PlcStartSL[794]: Parent kill
  • arj3090

    arj3090 - 2019-09-28


    I deleted everything in /var/opt/codesys/PlcLogic and now it downloads. But now I have a problem with the license. This license software used by Codesys has countless issues. This time I forgot to backup the license file before re-imaging my device. When I try to activate the license from my repository, it gives an error.

    I hope there are plans in the near future to move to a reliable licensing software.

  • arj3090

    arj3090 - 2019-09-29

    Something is very unstable with this kernel and Codesys version. It was working well, so I shutdown the device and took it to the office. Now it is back to the same error in the fist post. I tried deleting the boot project files again, but this time it did not fix it. It keeps closing out on the "ooops... this runtime was built for RASPBERRYPI (-25, 0x00000BB8, 0xFFFFFFFB)" error.

    I downloaded a very basic program to the device and it runs for about 10 seconds before dumping out of Codesys on the mentioned error.

    Before the kernel update, it ran for several days on the exact same piece of hardware.

    What could be causing the run-time to think it is not a Raspberry Pi?

    If this helps, this is the beginning of the debug information:

    PlcStartSL[776]: fork parent: 3074
    PlcStartSL[752]: fork child: ppid: 3072 1749
    ********* CoDeSysControl DEMO VERSION - runs 2 hours*********
    PlcStart[205]: using /etc/CODESYSControl.cfg as config file
    machine: armv7l
    timer resolution: 1nsec
    Linux version 4.19.71-rt24-v7+ (----------) (gcc version 7.4.0 (Ubuntu/Linaro 7.4.0-1ubuntu1~18.04.1)) #1 SMP PREEMPT RT Fri Sep 27 17:22:14 EDT 2019

    I also noticed it says "DEMO VERSION", but I just bought another license today and activated it. (second license for this same device)

  • nothinrandom

    nothinrandom - 2020-06-21

    Codesys was working fine on 4.14-RT, but it looks like I'm facing similar issue for 4.19-RT on a regular RPI 3B+. Are you reading from /tmp/codesysedge_debug.log? Nothing unusual shows up from its status except that Codesys exists 10-20 seconds after starting:

    $ service codesyscontrol status
    ● codesyscontrol.service - LSB: Prepares and starts codesyscontrol
    Loaded: loaded (/etc/init.d/codesyscontrol; generated; vendor preset: enabled)
    Active: active (exited) since Sun 2020-06-21 01:44:57 PDT; 9h ago
    Docs: man:systemd-sysv-generator(8)
    Tasks: 0 (limit: 4915)
    CGroup: /system.slice/codesyscontrol.service

    Jun 21 01:44:56 RevPi21689 systemd[1]: Starting LSB: Prepares and starts codesyscontrol...
    Jun 21 01:44:56 RevPi21689 codesyscontrol[7841]: License backup created
    Jun 21 01:44:57 RevPi21689 codesyscontrol[7841]: codesyscontrol started
    Jun 21 01:44:57 RevPi21689 systemd[1]: Started LSB: Prepares and starts codesyscontrol.



    Talk.ru: 1

Log in to post a comment.