Total noob having problem with Raspberry pi webvisu

sloob
2020-11-24
2020-11-25
  • sloob

    sloob - 2020-11-24

    Hi everyone!
    I'm a total noob when it comes to programming and I have a problem with my codesys program.
    it says it's missing a library but the download fails and I can't install it manually because I can't find this library anywhere on the internet.
    The library is CmpVisuHandler.

    I hope someone is able to help me.

    Thank you

     
  • eschwellinger

    eschwellinger - 2020-11-25

    I think the best approach is:
    You Update CODESYS to current version ( 3.5.16.30) + install the PI Package ( use the shopping cart icon in CODESYS)
    Then everything is in the same version and you will not see these problems.
    I think your device is an SP15 Version but your visu profile somehow SP16?

    The easy way is alwasy to have all in the same version.

    When ever you open an existing project with an newer CODESYS Version and you get 501 compile errors:

    1. Rightlick on the plc in the device tree -> update device to the current version
    2. use lates compiler version and visu profile

    -> then the compile should work without any issues.

    I you case I think the PI plc is an SP15 Version and maybe CODESYS SP16?

    This should work.

     
    πŸ‘
    1
  • Morberis

    Morberis - 2020-11-24

    Is it possible that it's being blocked from downloading the library? Either through antivirus etc or through a firewall or network filtering. I see that often at locations that use a white list rather than a black list for internet access. You shouldn't be able to navigate to the address listed there either if that's the issue.

    What you could do is right click on the CmpVisuHandler library in the library manager and click "properties'. Then select a different default library searching for "CmpVisuHandler"

    Regardless, here's a copy compressed using 7zip. You can see what libraries you have by navigating to C:\ProgramData\Codesys\Managed Libraries*library name*

    You can see that the zip file I attached includes a variety of versions. I haven't installed libraries in this manner before but try adding its contents to the appropriate folder.

    It might be worth checking out which visualization profile you have, listed in the project settings. Just in case its -None-.

     

    Last edit: Morberis 2020-11-24
    • sloob

      sloob - 2020-11-24

      Pardon my ignorance but I've added the folder in /programdata/codesys/managed libraries (It was already there but I overwrited it) but it's still not working.
      On a side note this issue appeared all of the sudden, I've been working on this project for a few hours and all was well, I could compile and simulate it with no problem but when I tried to upload it to my raspberry it gave me this error (all 500 of them)

      I've also tried to delete and re-add the library but it didn't work

      I also have the basic visu style

       

      Last edit: sloob 2020-11-25

Log in to post a comment.