Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Visualization stops responding

spiritcore
2021-07-21
2021-07-21
  • spiritcore

    spiritcore - 2021-07-21

    Hi,
    This is pretty urgent as we are in the end of a project and have to deliver it soon.
    The project is running on RPi 4 (we purchaed a license but it's not activated yet) and we have many sensors running on I2C and a few motors with drivers.
    When we run the code sometimes the borwser looses the connection with the WebVisu (that's how it seems) and no touch is available, the animated GIF on the screen is looping but when touching buttons is just doing nothing.
    The only solution is to refresh the browser and the touch is back again.
    I checked on the touchscreen of the RPi and also on an Android phone.
    If I refresh the browser on the phone it solves it on the phone but not on the touchscreen.
    When clicking on the Codesys visu running on a PC it does work.
    I tried looking on the chromium console (with TRACE enabled on the URL) but nothing interesting there.
    Any Codesys engineer that we can talk to and try to solve it?
    It's obvious that we can't share the project file for debugging here.
    Thanks!

     
  • eschwellinger

    eschwellinger - 2021-07-21

    Hi,
    for such cases is usually the Paid Support ticket from CODESYS store the right option.
    Do not forget to give the version info or even better would be to send the project archive to check

     

    Last edit: eschwellinger 2021-07-21
    • spiritcore

      spiritcore - 2021-07-21

      Ok,
      Thanks!

       

Log in to post a comment.