Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Problems trying cforge and checking out a repository

  • Morberis

    Morberis - 2020-08-06

    I ran into some things when trying to do follow this post and install SM3RaspiStepper. I was hoping to get some advice on where I went wrong. Or what went wrong.

    -I'm on 64bit windows 10
    -I've ran all the programs with administrator priviliges
    -Codesys 3.5.16 (64-bit) is not installed to the default directory but does have it's normal folder structure in the Program Files folder and CFORGE is present where it should be C:\Program Files\CODESYS\CODESYS\CFORGE
    -I've tried to use the Checkout with Cforge button with chrome, chrome with my extensions off, IE, tried with my antivirus/firewall off

    So here's what I did...
    1) installed Tortoise SVN and selected command line tools in installation
    2) installed Codesys SVN via the package manager
    3) downloaded and then installed cforge via the package manager
    4) followed the Cforge installation video and ran the Setup.bat file. I did not use the Setup.bat~. I also used the Setup.reg file after nothing was working.
    5) navigated to the SM3RaspiStepper page and tried clicking on the CHECKOUT using cforge button.

    Here's where the first problem came up. Watching the SVN checkout from CODESYS Forge video it looks like I should get a popup and I don't get a popup. Nothing happens when I click the button and you can see what I tried listed above for various combos.The command line tool did work though.

    So I continued...
    5a) I used the command prompt and it downloaded some files to C:/Users/username/drv,sm3raspstepper,code/ The command prompt tells me that it checked out revision 24
    6) tried to use the library repository to install either a compiled library file or a library file from sm3raspistepperdrv,sm3raspistepper,code\tags\Release_1.0

    Here is where I ran into another issue. The library repository didn't see a library that I could install in that folder or any of the sub folders. I also tried to add that location to the managed libraries directory, as well as to copy the folder into the existing managed libraries directory location. Neither seemed to work.

    So I moved on and...
    7) used the device manager to install the device descriptions from tags/release_1.0/devdesc.

    I did try to use the I think Codesys SVN as well. In codesys under Project->SVN->Checkout as well as the Repository Browser.

    In the Checkout window I pasted the http URL http://forge.codesys.com/svn/drv,sm3raspistepper,code/sm3raspistepper-drv,sm3raspistepper,code but got a warning exclamation mark that said

    Exception of type 'SharpSvn.SvnEntryNotFoundException' was thrown.

    The OK button was also greyed out. I did try it with the below appended at the front of the http address but that gives an error that it isn't a valid http address. I've attached a picture.

    svn checkout --username=morberis 

    In the repository window it would correctly give me a directory tree.

    Here is a pastebin link to the install log for cforge.

    Any advice would be great. I'm not entirely sure where to go from here.

    Edit: I'm sure it's something stupid I'm missing and probably something that I should know how to do but don't.


    Last edit: Morberis 2020-08-07
  • Ingo

    Ingo - 2020-08-11

    Hi Morberis,
    I had a look into the project and tried to reproduce your problems. Your main problem seems to be, that CODESYS SVN doesn't work properly. In your screenshot, I see an exception which should not be there.

    Normally it should look like this:


    Last edit: Ingo 2020-08-11
  • Ingo

    Ingo - 2020-08-11

    An additional information:
    During my tests I encountered an issue with CODESYS SP16 and the most current version of CODESYS SVN. I filed a bug report for the CODESYS SVN product, and added a workaround for cforge.

    So the most current version of cforge should already work much better.
    By the way: you don't need to run the two steps after installing the package. URL handlers and the Explorer Integration should work out-of-the-box.

    And when you are on the command line. The following command also worked for me:

    cforge --checkout "https://forge.codesys.com/svn/drv,sm3raspistepper,code/"
  • Morberis

    Morberis - 2020-08-11

    Thanks for the advice and help!

    Really what I have I think is 2 problems and I should have structured my first post better for that.

    • Like you say for some reason Codesys SVN doesn't seem to have installed correctly or something is being weird around that.
    • The second is possibly due to my lack of familiarity with projects like this. While I was able to use the command line tool like you suggest to download the project I'm unsure how to load the libraries. The device descriptions were recognized immediately being SM3_Drive_PosControl.devdesc and located @ sm3raspistepperdrv,sm3raspistepper,code\tags\Release_1.0\devdesc

    When I'm out of the field I'll monkey around and see if I can get Codesys SVN to work.


    Last edit: Morberis 2020-08-11
  • Morberis

    Morberis - 2020-08-11

    Hmm would the SVN error that you see be because I don't have CODESYS Professional Developer Edition. Instead I have a license key for Eatons version of codesys. I'm trying to do this in stock Codesys because their version is several versions behind. I need a license of some sort even in Demo Mode it looks like.

    To connect to an SVN repository, a license key is required in the demo as well as in the full version.

    So... what type of license key for demo operation? How do I get a demo license key? The package manager says no package required so I had thought that it was already operating with a demo license.

    I did try downloading a new copy and installing that but I get the same message you saw. I can also get this message, also attached below.

    Exception of type 'SharpSvn.SvnEntryNotFoundException' was thrown

    If I use the Repository Browser I see what you do but I don't have the OK button. Picture attached below.

    I can't install the newest version of Codesys SVN to Eatons Codesys but I can install SVN to Eaton's latest version which is Once SVN is installed the package manager lets me upgrade to but no further. The same messages pop up there and I also don't have an 'Ok' button.

  • i-campbell

    i-campbell - 2020-08-11

    Morberis, there is no library at the root of the svn repository, so it tells you there is no CODESYS svn project there.
    Try hitting the ellipses next to the HEAD button, and browsing through to tags/release_1.0/SM3_Drive_RasPiStepper/

    When the cforge project is working, it checks out all of the projects found in the repository and saves them as .projects or .libraries for you. Otherwise you have to do this CODESYS SVN checkout for all of them.


  • i-campbell

    i-campbell - 2020-08-11

    Sounds like the latest cforge release works with SP16 though if you want to try it. Checking out with Tortoise SVN will not work, because the objects are just stored as blobs and you have no way of assembling them back into a library.

  • Morberis

    Morberis - 2020-08-14

    Oh my goodness. I see I needed to open the Repository Browser through the Checkout window using those ellipses. Now the repository browser has an OK button and if I make a valid selection the OK button becomes selectable and that works and I feel like a fool. Thank you @i-campbell and @ingo for your help.

    I still seem to be having issues with at least the browser functionality of cforge though.

    TLDR, scroll to the very bottom. URL handler problems.

    Clicking the Checkout using Cforge button in my browser still does nothing. I did double check the CForge installation video and on my current browsers as well as a new install of Edge nothing happens when I click 'Checkout'.

    I've installed Cforge using the package manager, I've registered the URL handler and then registered the Explorer integration. I've uninstalled it, redownloaded it, and tried it a few times including making sure to run everything as administrator and having windows defender de-activated. Nothing changed after doing that.

    So now I've opened the setup batch file to see what is happening, what it does.

    1)It's running the cforge.exe in the same folder and using the --setup command.
    2) So I've manually run the cforge.exe file as an admin and it brings up the cmd prompt which displays some information and internal commands. Then that window tells me setup is finished and closes.
    3) The other 2 things that the batch file does it silently run the regedit Uninstall.reg and then setup.reg
    4) Ok so now I've manually run first the uninstall and then the setup registry files.
    5) The browser functionality still isn't working, even with a system restart
    6) Opening up the Setup file in Notepad I can see what it does. Unfortunately I don't know registry entries enough to know if it's adding registry entries, making changes, or in addition to doing those things or maybe instead of making/changing registries it's just referencing them and running that cforge.exe with commands like --update or --build. I do seem to have all of the registry entries. Like HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\CommandStore\shell\cforge.commit\command

    So is there anything I can check to see if things have installed correctly? If things are installed correctly is there anyway I can see what is going wrong?

    If the cforge explorer integration is working correctly should I have something for it in the right click menu like I do for Tortoise SVN?

    Edit: I'm currently trying Debug Cforge instructions. I do have another question about that... which process am I attaching visual studios debugger to? I do not see a Cforge process.

    I did place an empty text document named 'debug' in the same folder as the cforge.exe

    Edit 2: The cforge.exe does briefly tell me that the url handler is not registered.

    [WARNING] URL Handler is not registered. CFORGE: links will not work properly. Use Setup.bat to do this (at <CODESYS Installation folder>\CFORGE\ )

    However doing like it instructs and running the bat file is not registering the url handler. At least if I run the cforge.exe afterwards it gives me the same error.


    Last edit: Morberis 2020-08-14

Log in to post a comment.