#2 Which runtimes are supported?

None
2020-07-15
2019-06-03
aliazzz
No

CfUnit is verified on the following runtime versions (not exhaustive). If you have successfully ran CfUnit on a runtime system that is not yet listed here, please drop us an email and let us know so others can benefit from it too.

Sadly, we cannot guarantee this library to be compatible with all systems, though we strive for high inter-compatibility. All vanilla CODESYS runtimes from v3.5.14.x or higher are supported. OEM runtimes listed (or higher) are supported, but mileage may vary. Older runtime support in theory can work starting from 3.5.10.20 ( again, your mileage may vary, so try at your own luck). In case of older runtimes, some library references/dependencies should be swapped for older ones.

System Version Result Remark
CODESYS Control Win SL (x64) 3.5.14.x verified
CODESYS Control Win SL (x64) 3.5.15.x verified
CODESYS Control Win SL (x64) 3.5.16.0 verified
CODESYS Control for Raspberry Pi SL 3.5.14.x verified
CODESYS Control for Raspberry Pi SL 3.5.15.x verified
CODESYS Control for Raspberry Pi SL 3.5.16.0 verified
CODESYS Control Linux SL 3.5.14.x verified
CODESYS Control Linux SL 3.5.15.x verified
CODESYS Control Linux SL 3.5.16.x verified
CODESYS Control for BeagleboneBlack SL 3.5.10.30 verified
Schneider SoMachine ? verified
ABB Automation Builder v2.2.2 verified
WAGO e!COCKPIT ? verified [#48]
---------- ---------- ---------- ----------

Answers

  • aliazzz

    aliazzz - 2020-01-20
    • status: open --> closed
     
  • aliazzz

    aliazzz - 2020-05-01
    • Status: closed --> open
     
  • aliazzz

    aliazzz - 2020-06-02
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -1,13 +1,21 @@
    -**All runtimes from 3.5.14.0 or higher** should be supported. 
    +**All runtimes from v3.5.14.x or higher are supported without any known issues**
    
    -Older runtimes support may vary but in theory any runtime starting from 3.5.10.20 should work, but your mileage may vary (try at your own luck). In such a case some library dependancies should be swapped for older ones.
    +Older runtime support may vary but in theory any runtime starting from 3.5.10.20 should work ( but your mileage may vary, try at your own luck). In case of such older runtimes, some library dependencies should be swapped for older ones.
    
    -This library has been succesfully tested with the following system versions;
    +CfUnit is verified on following system versions (the list is not exhaustive).
    +If you have it running on your yet unlisted and it is not yet listed, please drop us a mail and we will add it to the list;
    
     System | Version | Result
     ---------- | ---------- | ------ 
    -CODESYS Control for BeagleboneBlack SL | 3.5.10.30 | no errors, no warnings
    -CODESYS Control for Raspberry Pi SL | 3.5.14.20 | no errors, no warnings
    -CODESYS Control Win SL | 3.5.14.20 | no errors, no warnings
    -CODESYS Control Win SL (x64) | 3.5.14.20 | no errors, no warnings
    -CODESYS Control Linux SL | 3.5.14.20 | no errors, no warnings
    +CODESYS Control Win SL (x64) | 3.5.16.0 | verified
    +CODESYS Control for Raspberry Pi SL | 3.5.16.0| verified
    +---------- | ---------- | ------ 
    +CODESYS Control Win SL (x64) | 3.5.15.x | verified
    +CODESYS Control for Raspberry Pi SL | 3.5.15.x | verified
    +---------- | ---------- | ------ 
    +CODESYS Control for Raspberry Pi SL | 3.5.14.x | verified
    +CODESYS Control Win SL | 3.5.14.x | verified
    +CODESYS Control Win SL (x64) | 3.5.14.x | verified
    +CODESYS Control Linux SL | 3.5.14.x | verified
    +---------- | ---------- | ------ 
    +CODESYS Control for BeagleboneBlack SL | 3.5.10.30 | verified
    
     
  • aliazzz

    aliazzz - 2020-07-15
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -1,21 +1,25 @@
    -**All runtimes from v3.5.14.x or higher are supported without any known issues**
    +**All CODESYS runtimes from v3.5.14.x or higher are supported without any known issues**
    +**OEM Runtimes listed (or higher) are supported, but mileage may vary, try at your own luck**
    
     Older runtime support may vary but in theory any runtime starting from 3.5.10.20 should work ( but your mileage may vary, try at your own luck). In case of such older runtimes, some library dependencies should be swapped for older ones.
    
     CfUnit is verified on following system versions (the list is not exhaustive).
     If you have it running on your yet unlisted and it is not yet listed, please drop us a mail and we will add it to the list;
    
    -System | Version | Result
    +System | Version | Result | Remark
    +---------- | ---------- | ------
    +CODESYS Control Win SL (x64) | 3.5.14.x | verified | -
    +CODESYS Control Win SL (x64) | 3.5.15.x | verified | -
    +CODESYS Control Win SL (x64) | 3.5.16.0 | verified | -
    +CODESYS Control for Raspberry Pi SL | 3.5.14.x | verified | -
    +CODESYS Control for Raspberry Pi SL | 3.5.15.x | verified | -
    +CODESYS Control for Raspberry Pi SL | 3.5.16.0| verified | -
    +CODESYS Control Linux SL | 3.5.14.x | verified | -
    +CODESYS Control Linux SL | 3.5.15.x | verified | -
    +CODESYS Control Linux SL | 3.5.16.x | verified | -
    +CODESYS Control for BeagleboneBlack SL | 3.5.10.30 | verified | -
     ---------- | ---------- | ------ 
    -CODESYS Control Win SL (x64) | 3.5.16.0 | verified
    -CODESYS Control for Raspberry Pi SL | 3.5.16.0| verified
    +Schneider SoMachine | ? | verified | -
    +ABB Automation Builder | v2.2.2 | verified | -
    +WAGO e!COCKPIT | ? | verified | Ticket[48]
     ---------- | ---------- | ------ 
    -CODESYS Control Win SL (x64) | 3.5.15.x | verified
    -CODESYS Control for Raspberry Pi SL | 3.5.15.x | verified
    ----------- | ---------- | ------ 
    -CODESYS Control for Raspberry Pi SL | 3.5.14.x | verified
    -CODESYS Control Win SL | 3.5.14.x | verified
    -CODESYS Control Win SL (x64) | 3.5.14.x | verified
    -CODESYS Control Linux SL | 3.5.14.x | verified
    ----------- | ---------- | ------ 
    -CODESYS Control for BeagleboneBlack SL | 3.5.10.30 | verified
    
     
  • aliazzz

    aliazzz - 2020-07-15
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -7,7 +7,7 @@
     If you have it running on your yet unlisted and it is not yet listed, please drop us a mail and we will add it to the list;
    
     System | Version | Result | Remark
    ----------- | ---------- | ------
    +---------- | ---------- | ---------- | ----------
     CODESYS Control Win SL (x64) | 3.5.14.x | verified | -
     CODESYS Control Win SL (x64) | 3.5.15.x | verified | -
     CODESYS Control Win SL (x64) | 3.5.16.0 | verified | -
    @@ -18,8 +18,8 @@
     CODESYS Control Linux SL | 3.5.15.x | verified | -
     CODESYS Control Linux SL | 3.5.16.x | verified | -
     CODESYS Control for BeagleboneBlack SL | 3.5.10.30 | verified | -
    ----------- | ---------- | ------ 
    +---------- | ---------- | ---------- | ----------
     Schneider SoMachine | ? | verified | -
     ABB Automation Builder | v2.2.2 | verified | -
     WAGO e!COCKPIT | ? | verified | Ticket[48]
    ----------- | ---------- | ------ 
    +---------- | ---------- | ---------- | ----------
    
     
  • aliazzz

    aliazzz - 2020-07-15
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -21,5 +21,5 @@
     ---------- | ---------- | ---------- | ----------
     Schneider SoMachine | ? | verified | -
     ABB Automation Builder | v2.2.2 | verified | -
    -WAGO e!COCKPIT | ? | verified | Ticket[48]
    +WAGO e!COCKPIT | ? | verified | Ticket [#48]
     ---------- | ---------- | ---------- | ----------
    
     
  • aliazzz

    aliazzz - 2020-07-15
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -21,5 +21,5 @@
     ---------- | ---------- | ---------- | ----------
     Schneider SoMachine | ? | verified | -
     ABB Automation Builder | v2.2.2 | verified | -
    -WAGO e!COCKPIT | ? | verified | Ticket [#48]
    +WAGO e!COCKPIT | ? | verified | Ticket [48]
     ---------- | ---------- | ---------- | ----------
    
     
  • aliazzz

    aliazzz - 2020-07-15
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -21,5 +21,5 @@
     ---------- | ---------- | ---------- | ----------
     Schneider SoMachine | ? | verified | -
     ABB Automation Builder | v2.2.2 | verified | -
    -WAGO e!COCKPIT | ? | verified | Ticket [48]
    +WAGO e!COCKPIT | ? | verified | Ticket[Tickets:#48]
     ---------- | ---------- | ---------- | ----------
    
     
  • aliazzz

    aliazzz - 2020-07-15
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -21,5 +21,5 @@
     ---------- | ---------- | ---------- | ----------
     Schneider SoMachine | ? | verified | -
     ABB Automation Builder | v2.2.2 | verified | -
    -WAGO e!COCKPIT | ? | verified | Ticket[Tickets:#48]
    +WAGO e!COCKPIT | ? | verified | [Ticket:#48]
     ---------- | ---------- | ---------- | ----------
    
     
  • aliazzz

    aliazzz - 2020-07-15
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -21,5 +21,5 @@
     ---------- | ---------- | ---------- | ----------
     Schneider SoMachine | ? | verified | -
     ABB Automation Builder | v2.2.2 | verified | -
    -WAGO e!COCKPIT | ? | verified | [Ticket:#48]
    +WAGO e!COCKPIT | ? | verified | [Tickets:#48]
     ---------- | ---------- | ---------- | ----------
    
     
  • aliazzz

    aliazzz - 2020-07-15
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -21,5 +21,5 @@
     ---------- | ---------- | ---------- | ----------
     Schneider SoMachine | ? | verified | -
     ABB Automation Builder | v2.2.2 | verified | -
    -WAGO e!COCKPIT | ? | verified | [Tickets:#48]
    +WAGO e!COCKPIT | ? | verified | [#48]
     ---------- | ---------- | ---------- | ----------
    
     
  • aliazzz

    aliazzz - 2020-07-15
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -8,18 +8,18 @@
    
     System | Version | Result | Remark
     ---------- | ---------- | ---------- | ----------
    -CODESYS Control Win SL (x64) | 3.5.14.x | verified | -
    -CODESYS Control Win SL (x64) | 3.5.15.x | verified | -
    -CODESYS Control Win SL (x64) | 3.5.16.0 | verified | -
    -CODESYS Control for Raspberry Pi SL | 3.5.14.x | verified | -
    -CODESYS Control for Raspberry Pi SL | 3.5.15.x | verified | -
    -CODESYS Control for Raspberry Pi SL | 3.5.16.0| verified | -
    -CODESYS Control Linux SL | 3.5.14.x | verified | -
    -CODESYS Control Linux SL | 3.5.15.x | verified | -
    -CODESYS Control Linux SL | 3.5.16.x | verified | -
    -CODESYS Control for BeagleboneBlack SL | 3.5.10.30 | verified | -
    +CODESYS Control Win SL (x64) | 3.5.14.x | verified |
    +CODESYS Control Win SL (x64) | 3.5.15.x | verified |
    +CODESYS Control Win SL (x64) | 3.5.16.0 | verified |
    +CODESYS Control for Raspberry Pi SL | 3.5.14.x | verified |
    +CODESYS Control for Raspberry Pi SL | 3.5.15.x | verified |
    +CODESYS Control for Raspberry Pi SL | 3.5.16.0| verified |
    +CODESYS Control Linux SL | 3.5.14.x | verified |
    +CODESYS Control Linux SL | 3.5.15.x | verified |
    +CODESYS Control Linux SL | 3.5.16.x | verified |
    +CODESYS Control for BeagleboneBlack SL | 3.5.10.30 | verified |
     ---------- | ---------- | ---------- | ----------
    -Schneider SoMachine | ? | verified | -
    -ABB Automation Builder | v2.2.2 | verified | -
    +Schneider SoMachine | ? | verified |
    +ABB Automation Builder | v2.2.2 | verified |
     WAGO e!COCKPIT | ? | verified | [#48]
     ---------- | ---------- | ---------- | ----------
    
     
  • aliazzz

    aliazzz - 2020-07-15
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -18,7 +18,6 @@
     CODESYS Control Linux SL | 3.5.15.x | verified |
     CODESYS Control Linux SL | 3.5.16.x | verified |
     CODESYS Control for BeagleboneBlack SL | 3.5.10.30 | verified |
    ----------- | ---------- | ---------- | ----------
     Schneider SoMachine | ? | verified |
     ABB Automation Builder | v2.2.2 | verified |
     WAGO e!COCKPIT | ? | verified | [#48]
    
     
  • aliazzz

    aliazzz - 2020-07-15
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -1,10 +1,7 @@
    -**All CODESYS runtimes from v3.5.14.x or higher are supported without any known issues**
    -**OEM Runtimes listed (or higher) are supported, but mileage may vary, try at your own luck**
    +**CfUnit is verified on the following runtime versions (not exhaustive). If you have successfully ran CfUnit on a runtime system that is not yet listed here, please drop us an email and let us know so others can benefit from it too.**
    
    -Older runtime support may vary but in theory any runtime starting from 3.5.10.20 should work ( but your mileage may vary, try at your own luck). In case of such older runtimes, some library dependencies should be swapped for older ones.
    +Sadly, we cannot guarantee this library to be compatible with all systems, though we strive for high inter-compatibility. All vanilla CODESYS runtimes from v3.5.14.x or higher are supported. OEM runtimes listed (or higher) are supported, but mileage may vary. Older runtime support may vary but in theory any runtime starting from 3.5.10.20 should work ( but your mileage may vary, try at your own luck). In case of such older runtimes, some library dependencies should be swapped for older ones.
    
    -CfUnit is verified on following system versions (the list is not exhaustive).
    -If you have it running on your yet unlisted and it is not yet listed, please drop us a mail and we will add it to the list;
    
     System | Version | Result | Remark
     ---------- | ---------- | ---------- | ----------
    
     
  • aliazzz

    aliazzz - 2020-07-15
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -1,6 +1,6 @@
     **CfUnit is verified on the following runtime versions (not exhaustive). If you have successfully ran CfUnit on a runtime system that is not yet listed here, please drop us an email and let us know so others can benefit from it too.**
    
    -Sadly, we cannot guarantee this library to be compatible with all systems, though we strive for high inter-compatibility. All vanilla CODESYS runtimes from v3.5.14.x or higher are supported. OEM runtimes listed (or higher) are supported, but mileage may vary. Older runtime support may vary but in theory any runtime starting from 3.5.10.20 should work ( but your mileage may vary, try at your own luck). In case of such older runtimes, some library dependencies should be swapped for older ones.
    +Sadly, we cannot guarantee this library to be compatible with all systems, though we strive for high inter-compatibility. All vanilla CODESYS runtimes from v3.5.14.x or higher are supported. OEM runtimes listed (or higher) are supported, but mileage may vary. Older runtime support in theory can work starting from 3.5.10.20 ( again, your mileage may vary, so try at your own luck). In case of older runtimes, some library references/dependencies should be swapped for older ones.
    
    
     System | Version | Result | Remark
    
     

Log in to post a comment.