#45 add a contribution.md

v1.1.0.0
closed
aliazzz
None
2020-06-15
2020-06-08
aliazzz
No

*This is a first draft for review, please submit any feedback =) *

Contributing to CfUnit

We love your input! We want to make contributing to this project as easy and transparent as possible, whether it's:

Reporting a bug
Discussing the current state of the code
Submitting a fix
Proposing new features
Becoming a maintainer

We Develop with CODESYS Forge

We use CODESYS Forge to host code, to track issues & feature requests.
Since CODESYS IDE is currently only using SVN, Pull Requests (PR's) are a bit of an issue currently.

Every code should be checked before submission:

  • Does your code have a test in the verifier?
  • No => write a test for the verifier
  • Yes => provide proof that your code and test works
  • After peer review and a working unittest in the verifier is provided, the code is eligible for merge in the trunk.

Any contributions you make will be under the MIT Software License

In short, when you submit code changes, your submissions are understood to be under the same MIT License that covers the project.
Feel free to contact the maintainers if that's a concern.

Report bugs using Codeys Forge [Tickets]

We use Tickets to track public bugs. Report a bug by opening a new ticket; it's that easy!

Write bug reports with detail, background, and sample code

Great Bug Reports tend to have:

  • A quick summary and/or background
  • Steps to reproduce
  • Be specific!
  • Give sample code if you can.
  • What you expected would happen
  • What actually happens
  • Notes (possibly including why you think this might be happening, or stuff you tried that didn't work)

Use a Consistent Coding Style

  • Never open/edit the trunk code! Instead, create a (local) branch under your own name and make your code adjustmensts there.
  • Make sure to keep the library settings and project information as the trunk project, except your version number.
  • Make sure that your CODESYS IDE uses spaces instead of tabs. The default behaviour of the CODESYS IDE is to use tabs so it needs to be changed. See Tools - Options - Text Editor - Editing - Untick "Keep tabs" and set tabwidth to 4

License

By contributing, you agree that your contributions will be licensed under its MIT License.

References

This document was adapted from briandk's excellent contribution guidelines template.

Discussion

  • aliazzz

    aliazzz - 2020-06-08
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -1,13 +1,14 @@
     *This is a first draft for review, please submit any feedback =) *
    
     # Contributing to CfUnit
    -If you wish contributing to this project, it should be as easy and transparent as possible, whether it's:
    +We love your input! We want to make contributing to this project as easy and transparent as possible, whether it's:
    
    -- Reporting a bug
    -- Discussing the current state of the code
    -- Submitting a fix
    -- Proposing new features
    -- Becoming a maintainer
    +    Reporting a bug
    +    Discussing the current state of the code
    +    Submitting a fix
    +    Proposing new features
    +    Becoming a maintainer
    +
    
     ## We Develop with CODESYS Forge
     We use CODESYS Forge to host code, to track issues and feature requests. 
    
     
  • aliazzz

    aliazzz - 2020-06-08
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -3,11 +3,11 @@
     # Contributing to CfUnit
     We love your input! We want to make contributing to this project as easy and transparent as possible, whether it's:
    
    -    Reporting a bug
    -    Discussing the current state of the code
    -    Submitting a fix
    -    Proposing new features
    -    Becoming a maintainer
    +Reporting a bug
    +Discussing the current state of the code
    +Submitting a fix
    +Proposing new features
    +Becoming a maintainer
    
    
     ## We Develop with CODESYS Forge
    
     
  • aliazzz

    aliazzz - 2020-06-08
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -16,10 +16,10 @@
    
     Every code should be checked before submission:
    
    -- Your code will/shall be reviewed by peers!
     - Does your code have a test in the verifier?
       - No => write a test for the verifier
    -- After peer review and a working unittest in the verifier is provided, the code is elligable for merge in the trunk.
    +  - Yes => provide proof that your code and test works
    +- After peer review and a working unittest in the verifier is provided, the code is eligible for merge in the trunk.
    
     ## Any contributions you make will be under the MIT Software License
     In short, when you submit code changes, your submissions are understood to be under the same [MIT License](http://choosealicense.com/licenses/mit/) that covers the project. 
    
     
  • aliazzz

    aliazzz - 2020-06-08
    • labels: contribution.md -->
    • status: pending --> closed
     
  • aliazzz

    aliazzz - 2020-06-08
    • status: closed --> open
     
  • i-campbell

    i-campbell - 2020-06-13

    License agreement appears twice under "License" and "Any contributions you make will be under the MIT Software License"
    "Unhook" might need to be Untick.

    How does someone without SVN write access submit their code? as attachment in the forge ticket?

    Should they have further questions about contribution, are we actually really excited about answering such questions? and if so how should they ask?

    Other than these questions, I think it is very good and may encourage some contributors.

     

    Last edit: i-campbell 2020-06-13
  • aliazzz

    aliazzz - 2020-06-13
    • Description has changed:

    Diff:

    --- old
    +++ new
    @@ -9,10 +9,9 @@
     Proposing new features
     Becoming a maintainer
    
    -
     ## We Develop with CODESYS Forge
    -We use CODESYS Forge to host code, to track issues and feature requests. 
    -Since CODESYS IDE is currently only using SVN, Pull Requests (PR's) are a bit of an issue.
    +We use CODESYS Forge to host code, to track issues & feature requests. 
    +Since CODESYS IDE is currently only using SVN, Pull Requests (PR's) are a bit of an issue currently.
    
     Every code should be checked before submission:
    
    @@ -43,7 +42,7 @@
     ## Use a Consistent Coding Style
     * Never open/edit the trunk code! Instead, create a (local) branch under your own name and make your code adjustmensts there.
     * Make sure to keep the library settings and project information as the trunk project, except your version number. 
    -* Make sure that your CODESYS IDE uses spaces instead of tabs. The default behaviour of the CODESYS IDE is to use tabs so it needs to be changed. See Tools - Options - Text Editor - Editing - Unhook "Keep tabs" and set tabwidth to 4 
    +* Make sure that your CODESYS IDE uses spaces instead of tabs. The default behaviour of the CODESYS IDE is to use tabs so it needs to be changed. See Tools - Options - Text Editor - Editing - Untick "Keep tabs" and set tabwidth to 4 
    
     ## License
     By contributing, you agree that your contributions will be licensed under its MIT License.
    
     
  • i-campbell

    i-campbell - 2020-06-15

    Sold

     
  • aliazzz

    aliazzz - 2020-06-15
    • status: open --> closed
    • assigned_to: aliazzz
    • discussion: enabled --> disabled
    • Milestone: testresult report --> v1.1.0.0
     
  • aliazzz

    aliazzz - 2020-06-15

    See root of SVN Repo