Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Exor PLIO6 Output Bug

2022-06-24
2022-08-16
  • Reinier Geers

    Reinier Geers - 2022-06-24

    I bought 2 Exor EX710 with a PLIO6 IO board. But from the 7 output i can only set the last 2 Output. The other are set back. Exor blaims Codesys. The solution seems te be a virtual windows 10 with a codesys version 14.40 . But thats no solution. Any one how knows more ?

     
  • h-hermsen

    h-hermsen - 2022-06-24

    Hi Reinier,

    We would very much be of help to you but sadly you described your problem not very clear.

    So in order for you to describe your issue more clear, I have a few questions/remarks.

    1) In general Exor provided the hardware and software, so they have the responsibility of helping you. Blaming CODESYS is not going to relieve them of this obligation. This means they are legally required to help you. Just follow their advice.

    2) What is "14.40"? is this CODESYS 3.5.14.40? If So you can always install CODESYS 3.5.18.10 and use the included CODESYS Installer to create a SP14.40 installation in parallel on the same machine, NO virtual guest necessary.

    3) Be sure to read up on the CODESYS Installer as it is a very handy and useful tool!

    4) What does "the other are set back" supposed to mean?
    Please describe your issue as if you are explaining it to a 6 year old ;-) Do provide more then enough details.

    regards

     

    Last edit: h-hermsen 2022-06-24
  • Reinier Geers

    Reinier Geers - 2022-06-27

    Hi,
    I bought it at a dealer. They have same problem.
    Yes version 3.5.14.40. I have several versions of codeys. Problem with version 18 is that most dont support, if de software is newer then the there version. My Dealer made the effor to find out that the virtual geast is working. The problem is to get them fix the problem. Set back means that is set the output to TRUE. Then the controller sets it back to FALSE. Ive you use a new programm and install the exor. It has the same problem. Whats a : read up on the CODESYS Installer ?

     
  • gatto

    gatto - 2022-06-27

    Hi, I use exor, I have installed Codesys 3.5.14.40 in a virtual machine with win 10.
    Once, I used the PLIO06 modules, now not anymore.
    However I still have a module here in the office and I have tried to make a project and control the outputs.
    Everything works for me.
    As you see in the figure.

     
    πŸ‘
    1
  • h-hermsen

    h-hermsen - 2022-06-27

    Read up on the CODESYS Installer > read documentation about codesys installer and benefit from using it. SP18 ships the installer, but you can do so much more with it like installing SP10 .. current and every version in between.

    So when you write a TRUE to output to the exor output channel, the Exor writes it back to FALSE. Yes this sounds like some other process is writing the same channel. This symptom could be caused by multiple issues, so without proper equipment its hard to guess what is going on. Just some ideas, you have probably thought so yourself;

    1) Maybe check the IO settings tab in the hardware on the channel behavior, try several settings,
    2) Check IO behaviour of the PLC in the PLC settings and try several settings,
    3) check your program if you write the output in multiple statements,
    4) In general try to exclude anything software related in your project, this way the vendor can easily see its a "bug" in their output FB IoDrv

    If the issue persists, write a dmall demonstration program and make a full projectarchive and share it with your reseller (i.e. dealer). Maybe also upload the projectarchive here.

    PS a virtual machine / windows 10 etc has got nothing to with issue as gatto allready showed

     

    Last edit: h-hermsen 2022-06-27
  • Reinier Geers

    Reinier Geers - 2022-06-27

    Getto Showed that de virtual is working. But thats a macgiver solotion. I tried a version 17. But then it has a problem with the current visualization version. Codesys changes to mutch so newer version always add new problems. the newest is version 18. Still no working version.

     
  • gatto

    gatto - 2022-06-27

    Hi, English is not my native language,
    I always try to write in a simple way so that English and non-English people can understand me.
    I have a lot of trouble understanding your latest post.
    however you cannot use any version of codesys for exor hmi.
    The version depends on the runtime of the project jmobile studio.

    From what I remember, for a while with jmobile 2.8 they used codesys 3.5.10 then with jmobile 4.0 they used codesys 3.5.14.
    Now they just released jmobile 4.5 and I don't know which version of codesy is used.

    For now I keep using jmobile 4.0 and then codesys 3.5.14.40.

    Regardless of the jmobile version and therefore the associated codesys version:
    First you need to download jmobile hmi project, after (under jmobile studio) activate codesys license and finally with IDE of codesys you can manage the plc.

     
  • gatto

    gatto - 2022-06-27

    last but not least:
    jmobile studio and related ide codesys must be downloaded from the exor site which also provides the package with the ex700 target

     
  • Reinier Geers

    Reinier Geers - 2022-08-16

    After update to version 16 problem solved.

     

Log in to post a comment.