Codesys won't launch

  • domi-nik - 2023-02-16


    for the past two days i've been trying to install CodesysV3. I've tried multiple ways (via the launcher and via the .exe). Both of which are able to install Codesys but upon launch no window opens but I can see something open in the taskbar.
    I tried installing version Installing 3.5 SP17 works perfectly. However for a new project I want the start with the latest codesys version.
    In between the new installations i've tried deleting all contents relating to codesys of 'local', 'roaming' and 'appdata' as well as 'programs' nad 'programsx86'. I also reinstalled codemeter at some point of the whole process
    Anyone able to help me out here?

  • snhatton - 2023-03-13


    Sometimes the install is interrupted when anti-virus software is enabled. Can you try doing a full uninstall, turn off any antivirus software and try the install from Codesys installer. Make sure you run this as administrator. You can also start a custom event logger in windows to help you identify what the issue is. I've attached a screenshot with the configuration options. Please let me know if you have any questions or concerns. Hope this helps!

  • domi-nik - 2023-03-14

    Hey i've actually mangaged to fix the problem. I can't 100% point to where the issue lies but it must've been some kindof user based setting.
    So if you're encountering similar problems you'll have to delete every single codesys affiliated folder.
    In my case I think I missed one under C:\Programs.

    Thanks for reaching out anyways :)


Log in to post a comment.