Creating Unit Test

2019-08-01
2019-08-05
  • PauloRicardoSS

    PauloRicardoSS - 2019-08-01

    Hello Fellas,

    I have a problem.

    I am using the Test Manager for the first time.
    I am able to use Test Cases without any problem.

    But, when I try to create a simple unit test using test tables, I got this fault:

    "Attempt to write an object with read-only access. (Object: 'PLC_PRG [Device: Plc Logic: Application]"

    I checked my PLC_Prog , to make sure that everybody can have all access to this routine, but I still receive the same messages, I tried using the runtime and the simulation and the results are the same.

    Can anyone help me? Unfortunately, I couldn't find this fault in anywhere.

    Thanks a lot

     
  • mkeller

    mkeller - 2019-08-01

    Hi.

    PauloRicardoSS hat geschrieben:
    "Attempt to write an object with read-only access. (Object: 'PLC_PRG [Device: Plc Logic: Application]"

    Is the text from a compile message in the Message view?

    BR
    Martin

     
  • PauloRicardoSS

    PauloRicardoSS - 2019-08-01

    M.Keller hat geschrieben:
    Hi.
    Is the text from a compile message in the Message view?
    BR
    Martin

    I think this attached image can help

    IMG: UnitTestFault.PNG

     
  • PauloRicardoSS

    PauloRicardoSS - 2019-08-05

    Anyone?
    I follow the webinar to create the unity test using a table, also I create a new project and always got this fault, I am trying to understand which step I am missing.

     

Log in to post a comment.