Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

CoDeSys forced GPIO to FALSE in project with profinet master

asivakov
2021-06-11
2022-01-28
  • asivakov

    asivakov - 2021-06-11

    Hello!
    I am using Pigeon RB300-CM (plc-like Raspberry Pi 3) with runtime of 4.0.1.0 and CoDeSys 13.5 SP16 patch 4.
    Recently I noticed that my program didn't affect on GPIO output ports.
    I tried to force output in TRUE, but still nothing.
    I tried to change value by "gpio write" in linux console - and it worked! But only when codesys app stopped. After start gpio turned to false, so trouble definitely in project. Looks like something blocking all GPIO's at start.

    Minimized project attached (one output in TRUE and profinet master). You can try any other Pi or ports.

    I'll be very appreciate if someone will help me. Thx.

     

    Last edit: asivakov 2021-06-11
  • asivakov

    asivakov - 2022-01-28

    Need to set IO task

     

Log in to post a comment.