Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Invalid Result Package

  • martinll

    martinll - 2021-09-30


    I created a FB and filled it with some code (nothing special at all), then i added and later moved it in my PLC_PRG (I think i did this without anything unusual happening.

    Now when i try to go online i get "invalid result package" and codesys freezes for about 30 seconds.

    I have tried removing the created FB and rebuilt and restarted codesys (also restarting the Codesys PLC and Gateway) but it does not help and i donΒ΄t relly know how to sole this.

    When i go online in simulation mode it works but when i try to connect through OPC UA to the Codesys Control win V3 -x64 version the "invalid result package" appears.

    I get the Device [Connected] (Codesys Control Win V3 x64) in green at the top of the device-menu but the the "invalid result package" appears. If i press details i see and empty "log message" "code position" and "library".

    I have now tested to remove everything from the PLC_PRG, re-building and testing with no success.

    I have also tried to repair the install but without any changes regarding the problem.

    There is no information on the Codesys homepage and here in Codesys forge there are a couple of older, unanswered questions regarding the same issue.

    Does anyone have any Ideas?

    Codesys v3.5 SP16 Patch 1+ (64-bit)




    Last edit: martinll 2021-09-30
  • martinll

    martinll - 2021-09-30

    Last edit: martinll 2021-09-30
  • abtimj

    abtimj - 2022-04-13

    Did you get this working at all?

    I've searched for "Invalid result package" on this forum, and for every single entry, there are no answers. Is there no one from CODESYS that can answer?

  • sean-barton

    sean-barton - 2022-08-31

    Yes, I've had this happen too. In my case, there was a problem with not having generated files for system components like alarm manager, persistence manager, etc.

    What I did to fix this was:
    Select "Generate" from the "Composer" menu (NOT "Generate, Build and Login")
    Select "Clean all" from the "Build" menu
    * Login

    Before the above procedure, my code was acting very strange, sometimes reporting problems on build where there were no problems and methods showing as invalid on one line of code, but on the line above the exact same method was valid. After performing the above procedure, there are no longer any code errors and the "Invalid Result Package" does not come back.


    Last edit: sean-barton 2022-08-31
  • vincentger

    vincentger - 2022-11-30

    I am using a Raspberry Pi with Runtime and Codesys SP 18.0 and have the same error message. It seems like the steps described by SEAN_BARTON dont work for me. I am able to deinstall the runtime and reinstall it and get it to work afterwards but otherwise it keeps on failing on the invalid paket result. Any other solutions out there?

  • sean-barton

    sean-barton - 2023-01-25

    Another method I was able to get to work was to ssh into the device and remove all contents from the /opt/CODESYS/PlcLogic/Application folder. Once the old application was removed from the device, a fresh download from the IDE resulted without the error.

    An alternative to the above may be to create an empty project for the device and simply login, replacing the existing application on the device with an empty one, then reload the desired project after. Resetting the origin while online with the empty project may also be required, but this will likely clear any persistence manager data - if that is applicable to you.


Log in to post a comment.