Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Webvisu chrashes during login

  • captaincookie

    captaincookie - 2021-12-07


    I'm using the Codesys version V3.5 SP17 Patch 2, with the current visu packages Codesys Installer does no display any updates, so I think it's up to date. I implemented a webvisu with user login and before I updated from SP17 Patch 1 to Patch 2 everything worked fine for a long time. But since the update the web visu crashes when clicking on the ok button to confirm the login. Two screenshots is attached. Using Codesys to to log in to my device, I can use the visu properly. Inside of Codesys it works, but not in the Browser. It's not depending on the browser nor the computer. I tried it in Firefox, Edge and Chrome and on different PCs. The white rectangle, which is displayed after the login attempt also occures in every browser and is part of the crash. It should not be there. The visu needs to be reloaded. But it's sufficient to reload the window in the browser. This error does not affect Codesys, so there are no errors or warnings written in the logs. Any ideas how to fix it?

    Thanks in advance.

  • CellOHorst

    CellOHorst - 2021-12-09


    Same problem here; some more pieces of information:

    • same happens with CODESYS visualisation - last working version is
    • it happens with every edit box as soon as for writing the variable the check-box 'Password-field' is checked
    • seems that then it is not possible anymore to leave the edit box
  • m.prestel

    m.prestel - 2021-12-10

    Please report this bug via the store.

    I think enabling "Support client animations and overlay native elements" in the visu manager solves the issue.

    Best regards,

  • CellOHorst

    CellOHorst - 2021-12-11

    Hi Marcel,

    Thanks a lot - your solution works!
    (Raises some other problems - but we're working on those anyway).

    I had reported that bug already a while ago but never got any response.
    Attached the mail I had sent.

    Kind regards,

  • captaincookie

    captaincookie - 2021-12-13

    Hi Marcel,

    that solution works in my project too. Thanks a lot.

    Best regards.


Log in to post a comment.