Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Not able to see input data coming from eip adapter on codesys

  • SumNature - 2024-02-29

    Hello there,

    I have an eip adapter running (remotely) that is sending data back to eip scanner (running on codesys). I can send data from scanner (codesys) to the adapter but not getting the data back from the adapter. I have verified the incoming data on wireshark but I don't see this data in the codesys. I have tried local variable mapping and global variable mapping not variable values just stays at 0.

    Please guide.

  • dhumphries - 2024-03-02

    Does the device have a green icon next to it when the PLC is running? If not you have some kind of communication problem, wireshark may be picking up some data but the scanner may not be configured correctly to receive the data. Check the T>O and O>T bytes and make sure they match on both the scanner and adapter. I've had very little success loading a .eds file and having the configuration work without some manual configuration.

    If you have a green icon, have you enabled the device to always update variables?


    Last edit: dhumphries 2024-03-02
  • SumNature - 2024-03-06

    Yes, green icon is there, this time I tried by enabling the device to always update variables but results are the same. I have attached the screenshot and eds file I am using.


    Last edit: SumNature 2024-03-06
  • dhumphries - 2024-03-06

    The green icon with an ! next to the device is concerning. Is the data type correct for the input, you are using a byte input but the description says string. Is there anything useful in the status tab?

  • SumNature - 2024-03-07


    I changed the datatype this time from BYTE to USINT (because that's what my adapter is sending: array of uint8_t).
    The text "New Help String" you saw in previous screenshots is just the description of the input/s (it can be anything).
    I also looked into the logs (see attached) for that ! sign next to the device, I found that connection is being timeout. I tried some suggestions from online such as increase the RPI but still got connection timeout issue, also by changing the datatype, I still don't see incoming data from the adapter, although its visible on wireshark.


  • i-campbell

    i-campbell - 2024-03-07

    Hello, I think you can try to change the Connection from Multicast to Point to Point. Please also make sure your windows firewall is allowing the correct UDP ports inbound for ethernet IP.

    You might also need to increase the RPI, so it times out slower.

  • SumNature - 2024-03-07


    Thank you the suggestion, issue was the windows firewall not allowing the UDP traffic to pass through for EIP.
    thanks again


Log in to post a comment.