API Reference

h-hermsen

Compatibility

Though we strive for high interopatibility, the reality is that we cannot guarantee this library is compatible with all systems though it has been verified to work with most popular CODESYS Runtimes

  • All CODESYS runtimes from v3.5.10.20 or later are supported.
  • Original Equipment Manufacturer (OEM) CODESYS Runtimes listed (or higher) are supported
  • Unlisted or older runtimes can work starting from 3.5.10.20 (your mileage may vary, so try at your own luck). In case of older runtimes, some library references/dependencies should be swapped for older ones.
System Version Result Remark
CODESYS Control Win SL (x64) 3.5.17.x verified
CODESYS Control Win SL (x64) 3.5.16.x verified
CODESYS Control Win SL (x64) 3.5.15.x verified
CODESYS Control Win SL (x64) 3.5.14.x verified
CODESYS Control Win SL (x64) 3.5.13.x verified
CODESYS Control Win SL (x64) 3.5.12.x verified
CODESYS Control Win SL (x64) 3.5.11.x verified
CODESYS Control for Raspberry Pi SL 3.5.17.x verified
CODESYS Control for Raspberry Pi SL 3.5.16.x verified
CODESYS Control for Raspberry Pi SL 3.5.15.x verified
CODESYS Control for Raspberry Pi SL 3.5.14.x verified
CODESYS Control for Raspberry Pi SL 3.5.13.x verified
CODESYS Control for Raspberry Pi SL 3.5.12.x verified
CODESYS Control for Raspberry Pi SL 3.5.11.x verified
CODESYS Control for BeagleBoneBlack SL 3.5.10.30 verified
ABB Automation Builder v2.4.x verified
ABB Automation Builder v2.3.x verified
ABB Automation Builder v2.2.x verified
ABB Automation Builder v2.1.x verified
ABB Automation Builder v2.0.x verified
Schneider SoMachine ? verified
WAGO e!COCKPIT ? verified [#48]
---------- ---------- ---------- ----------

API References for version

[v1.0.0.0]
[v1.2.0.0]