Personal Data

Username:
dcjarle
Joined:
2022-01-05 07:48:50+00:00

Projects

  • No projects to display.

Skills

  • No skills entered.

User Activity

  • Posted a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    Hi I'm tying to get run a PFC200 as modbus TCP master against a BFI H3 VFD. Beijer provides a library that includes a function block that handles the communication between X2/BoX2 Control and the BFI-H3 VFD. The thing is that this function block takes ModbusTCPSlave as input. When I configure the modbus network on the Wago everything have Diag in the type. E.g. IoDrvEthernetDiag IoDrvModbusTCP_Diag ModbusTCPSlave_Diag This throws an error when connecting the ModbusTCPSlave_Diag since the FB expects...

  • Posted a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    Yes the error is still there.

  • Modified a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    So i got all IO modules connected and PLC online. PLC might have some conflict with e!cockpit since it was running that, before i switched. At least it works now. Not able to see anything about e!Cockpit in wbm, since swaping to codesys 3.5. Storage does not seem to be full. df returns: Filesystem 1K-blocks Used Available Use% Mounted on /dev/root 292251 113365 159277 42% / devtmpfs 250420 60 250360 0% /dev none 250932 72 250860 0% /tmp none 250932 0 250932 0% /media none 4096 128 3968 3% /var/log...

  • Posted a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    So i got all IO modules connected and PLC online. PLC might have some conflict with e!cockpit since it was running that. At least it works now. Not able to see anything about e!Cockpit in wbm, since swaping to codesys 3.5. Storage does not seem to be full. df returns: Filesystem 1K-blocks Used Available Use% Mounted on /dev/root 292251 113365 159277 42% / devtmpfs 250420 60 250360 0% /dev none 250932 72 250860 0% /tmp none 250932 0 250932 0% /media none 4096 128 3968 3% /var/log none 250932 100 250832...

  • Posted a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    Update: I removed some of my IO modules, so that i was left with only a 750-1506 and and the end-terminal. This got the program running. Will do some more testing to see if one of the modules are faulty. I do however still get the could not create the directory error.

  • Posted a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    Can confirm that i have a 750-600 end module connected. I had everything running fine with e!Cockpit before i decided to try codesys.

  • Posted a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    I am trying to get a PFC200 to run on codesys. I am able to add the internal bus and the device is shown as active, but when I go to the bus it's status says PFC200Bus: Not running. I seem to be able to compile and download programs, but IO interactions wont work. When scanning for connected devices i get a kbus error. There also a could not create directory /var/run/codesyscontrol/ error. Setup: pfc200 8212 fw 03.07.14(19) runtime V4.3.0.0 CODESYS Sp17 Patch 2 Any suggestions on how to solve th...

View All