Personal Data

Username:
ramas
Joined:
2022-02-09 13:17:27+00:00

Projects

  • No projects to display.

Skills

  • No skills entered.

User Activity

  • Posted a comment on discussion Runtime πŸ‡¬πŸ‡§ on CODESYS Forge

    Hey, I very new to codesys I hope someone can point me in the right direction here. So basically, I am making a testing-software for my department, i have written all the python scripts for it. the software basically tests a DUT for some anomalies. This testing-software GUI must be done in Codesys which can be simply done with the visualization manager. This software will run on a Raspberry Pi(4) with codesys runtime on it but I am making the software on a Windows pc.The raspberry Pi serves as the...

  • Posted a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    Hey guys, I have been trying to establish a connection to the raspberry pi, I have also bought the license(Rpi MC SL) and it is on the dongle. On the RPI on eth1 there is a LAN connection to the network i am in(i have pinged it). As you can see in the pictures when i try to connect it, it shows that "no device is responding to the scan request" error. Can someone help me figure out what the problem is? i have already installed the linux gateway. HOWEVER i was able to install the runtime package to...

  • Posted a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    Hey guys, I have been trying to establish a connection to the raspberry pi, I have also bought the license(Rpi MC SL) and it is on the dongle. On the RPI on eth1 there is a LAN connection to the network i am in(i have pinged it). As you can see in the pictures when i try to connect it, it shows that "no device is responding to the scan request" error. Can someone help me figure out what the problem is? i have already installed the linux gateway. HOWEVER i was able to install the runtime package to...

  • Posted a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    Yes thank you hapeter that was the problem, I am relatively new to codesys hence the rather amateur questions.

  • Posted a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    Thank you but that did not work. SysFile.SysFileCopy is being called as a function, i can see it in the Call tree but the file is not being copied into the directory. I wonder why

  • Posted a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    Thank you for the feedback i will try it without sudo!, But i think there is something wrong with the code in itself. Which would explain why there are red lines as you can see in the attachment "POU.png".

  • Posted a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    Thank you for the feedback i will try it without sudo!, But i think there is something wrong with the code in itself. Which would explain why there are red lines as you can see in the attachment "POU.png".

  • Modified a comment on discussion Engineering πŸ‡¬πŸ‡§ on CODESYS Forge

    Hey guys so I am trying to run a python script during codesys runtime but i am getting a lot of errors in the POU, there are red underlines, I do not understand what i am doing wrong here. I have added the necessary libraries to run python while codesys runtime and followed the necessary steps, The python file should be copied into /var/opt/codesys and there is a log file that will also be created to log in the current time. However there seems to be a problem with my POU or the libraries are not...

View All