Personal Data

Username:
wib-jens
Joined:
2021-07-14 12:17:49+00:00

Projects

  • No projects to display.

Skills

  • No skills entered.

User Activity

  • Modified a comment on discussion Deutsch 🇩🇪 on CODESYS Forge

    Hallo, also die Kommunikation über die Kanäle und auch über die Bibliothek hab ich jetzt hinbekommen. Die Lösung lag wahrscheinlich in zwei Dingen, Die uiUnitID darf trotz TCP/IP nicht 255 sein sondern muss der richtigen Slave ID entsprechen (IP-Adresse und Port scheinen nicht auszureichen, ich dachte ich hätte in der Doku gelesen, das bei ModbusTCP dieser Parameter irrelevant ist) und ... die ResponseTime beim reelen System darf nicht 50ms entsprechen (logisch). Mit den 3000ms funktioniert es :...

  • Posted a comment on discussion Deutsch 🇩🇪 on CODESYS Forge

    Hallo, also die Kommunikation über die Kanäle und auch über die Bibliothek hab ich jetzt hinbekommen. Die Lösung lag wahrscheinlich in zwei Dingen, Die uiUnitID darf trotz TCP/IP nicht 255 sein sondern muss der Salve ID entsprechen (IP-Adresse und Port scheinen nicht auszureichen) und ... die ResponseTime beim reelen System darf nicht 50ms entsprechen (logisch). Mit den 3000ms funktioniert es :o)

  • Posted a comment on discussion Deutsch 🇩🇪 on CODESYS Forge

    Hallo GordiTron, ja, ich meine Modbus IP (TCP). Ich habe beide Varianten versucht Bibliothek (ModbusFB 3.5.17.0) und auch die "Standard" Kopplung über die Geräteeinstellungen/Hardwarekonfig. Auch in der Hardwareeinstellung scheitert es nachdem ich einen Kanal mit z.B. ReadCoil einfüge, Ohne irgendeine Abfrage darin geht auch dort die Verbindung (Socket). Als Gegenstelle habe ich zunächst auch EasymodbusTCP genutzt. Mit der PV Anlage können wir schon über einen Beckhoffsteuerung (ModbusTCP) kommunizieren....

  • Posted a comment on discussion Deutsch 🇩🇪 on CODESYS Forge

    Hallo, also bei mir geht es mit Codesys 3.5.17.0 und der RP Runtime 4.0.0.0. Wie sehen bei euch die Firewalleinstellungen aus? Ich hab bei mir zwei "Gateway Service" Einträge gefunden, jeweils TCP und UDP alle Port eingehend geöffnet ... Ich bekomme jedoch keine Modbuskommunikation vom RasPi zur PV Anlage/PC-Modbus Simulations Server hin. Socketaufbau geht, aber die Requestbausteine sagen nur "RequestNotProcessed" ... k.a. warum das nicht geht.

View All