snguyen - 2021-03-31


I have a problem that I cannot find the solution to.

I have CodeSys 2.3 installed on my computer to program IFM controllers, and I decided to download CodeSys 3.5 patch 4 from IFM's website and when I installed 3.5, the font size and type in CodeSys 2.3 changed in some place.

I tried uninstalling CodeSys 2.3 and 3.5, deleted folders in %USER%/appdata and %USER%/documents, clean install codesys 2.3 only and nothing worked.
I tried changing screen resolution and dpi settings.
I tried resintalling fonts.
I searched for keys in windows registry that would indicate font size but I can't find anything.

It is not the first time I have this problem and it's systematically when I install codesys 3.5 patch 4 from IFM's website. Last time, I reinstalled windows.

The biggest problem is that I can't Add/remove the network variable tab in a global variable property page. This prevents me to work.

Also, the bug seem to have change the font of the installer too.

In attachments, you can see normal font taken from another computer, and the computer I'm working with.

Does anyone know a solution to this?