Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Thermokon STC65-RS485 EVC an Wago 750-841

Deutsch
grauerwolf
2014-04-02
2014-04-16
  • grauerwolf

    grauerwolf - 2014-04-02

    Hallo,
    hat jemand schon mal ein Telegramm von(!!) der Wago an(!!) ein EnOcean-Teil geschickt.
    Ich habe das Beispiel-Programm von Wago mit der EnOcean_lib_05 genutzt.

    Von einem Taster zur Wago geht alles (Empfangen).

    Taster >> STC65 >> 750-652 >> 750-841

    Aber beim Senden zu einem EnOcean-Schalter(z.B.) komme ich nicht zurecht. Wie wird die ID festgelegt, an die ich sende ??

    Viele Grüße
    grauerwolf

     
  • Anonymous - 2014-04-06

    Originally created by: 61131

    Hallo,

    ja, interessantes Thema. Inzwischen habe ich eine Applikation mit ca. 10 EO Sensoren und 8 Aktoren sowie einige Fensterüberwachungen am Laufen.

    Auf die Schnelle 2 Hinweise:
    a) Für das Senden verwende ich:
    - FbThermokonSTC65_RS485_EVC: Als Schnittstellenbaustein (sollte bei dir schon laufen)
    - FbQueryStationAddress: Wichtig für die Ermittlung der Basis-Adresse des EVC. Über ein Triggersignal lese ich dami die Adresse aus.
    - FbShow_ID_ByClick und EO_SHOWME: Für das Senden nicht wichtig...
    - FbEnoceanSendButtonSignal : Damit wird das SENDESIGNAL auf EO-Ebene für die Aktoren gebildet (EEP F6-02-01/05-02-01 oder F6-02-02/05-02-02). Mit HIlfe eines Offset und der Basis-Adr. (s.o.) gibst du die ID an.

    Mit Hilfe der WAGO Doku zu LIB und den o.g. Bausteinen solltest du es zum Laufen kriegen.

    b) Kleine Anmerkung:
    - Wichtig: Das EVC NICHT auf "Telegrammwiederholung" stellen, bring Probleme.
    - Für die Konfiguration verwende ich Fb_EVC_Config und dem zugehörigen VISU-Objekt
    - Im Gespräch mit dem netten WAGO Support haben wir 1 oder 2 Unschärfen in der LIB festgestellt, daraufhin hat WAGO mir eine korrigierte LIB zugeschickt. Ich weiß nicht, ob die Änderungen schon in der LIB zum Download eingeflossen sind. Die Unschärfen sind aber auch eher "besser Wohnen" Natur und nicht essentiel.

    Okay, soweit zunächst. Vielleicht hilfts, wenn nicht, kann ich gerne weitere Tipps geben. Aktuell läuft die EO-Intallation sehr stabil und mein "Kunde" ist sehr zufrieden.

    Viel Erfolg,
    MJK

     
  • Anonymous - 2014-04-07

    Originally created by: mg

    ... vielleicht hilfts:

    Ich verwende die Ethernet-Variante von Thermokon.
    http://www.oscat.de/community/index.php?topic=1016.0

    Inzwischen stimmen die Aussagen über Dolphin und den Trafo nicht mehr der Rest ist immer noch aktuell.

     
  • grauerwolf

    grauerwolf - 2014-04-16

    Hallo,
    jede Menge Asche über mein Haupt. Man muss den STC65-RS485 auch richtig anklemmen. Ich hatte die Brücken von Anschluss 1 zu 2 und 5 zu 6 vergessen herzustellen. Damit konnte ich zwar empfangen aber nicht senden.
    Richtig angeklemmt funktioniert das Beispiel-Programm von Wago hervorragend. Man kann alle möglichen Sensoren/Empfänger testen und begreift dann auch schnell die ganze Technik.
    Aber was nutzt ein Ferrari, wenn man vergisst zu tanken !!

    Viele Grüße
    grauerwolf

     

Log in to post a comment.