Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Anzeigefehler mit Client-Animation in Raspberry Pi

r1pp3r
2021-09-15
2021-09-16
  • r1pp3r

    r1pp3r - 2021-09-15

    Ich habe eine Hausautomation bei mir am Laufen, bestehend aus Raspberry Pi und Codesys V17 Patch1 inklusive ML Runtime V4.2.0.0.

    Auf dem Raspberry läuft die WebVisu in einem eigenen Task und an eine eigene CPU gepinnt.

    Wenn ich die Client-Animation im Visualisierungsmanager aktiviere habe ich den unschönen Effekt, dass beim Bildwechsel alle Frames ganz kurz oben in der Ecke erscheinen und ein paar Millisekunden später an ihrem richtigen Platz sind. Dieses Verhalten betrifft scheinbar nur die Frames, andere Element wie Button, Text, Grafiken bleiben relativ gesehen am richtigen Ort.
    Ich konnte dieses Verhalten in 2 Screenshots festhalten, so sieht das beim Umschalten immer kurzzeitig aus.
    Schalte ich die Client-Animation aus ist alles i.O. und die Frames erscheinen beim Umschalten direkt am richtigen Platz.

    Hat einer eine Idee, ob ich was falsch eingestellt habe oder ob das eher in Richtung Bug geht?

    Achso, es ist auch Browserunabhängig.

    Gruß
    Ron

     
  • m.prestel

    m.prestel - 2021-09-16

    Hallo @r1pp3r,

    aktualisierst du die Webvisu mit einem F5, wenn du den Overlay Hacken setzt und wieder weg nimmst?

    LG
    Marcel

     
  • r1pp3r

    r1pp3r - 2021-09-16

    Guten Morgen,

    wenn du im Webbrowser meinst, ja. Die Visu wird dann neu geladen und danach sind die effekte zu beobachten.
    Ich habe auf der Startvisualisierungsseite einen Frame und in diesem werden die "Untervisualisierungen" angezeigt. Beim Umschalten dieser Anzeige tauchen die Effekte auf.

    Habe das Projekt nach der Umstellung auch schon komplett neu kompiliert und auf den Raspberry geladen, hat alles nix geholfen. Muss dazu sagen, ich komme aus der Automatisierungsrichtung und bin mit dem kompilieren, laden der Steuerung und ggf. Urlöschen/Rücksetzten vertraut.

    Es sieht aus, als würde man z.B. in Powerpoint eine Fernsterwechselanimation mit sehr sehr kleiner Verzögerungszeit laufen lassen. Gibt es mit der Overlay Funktion eventuell solche Animationen für Frames, ich habe dazu aber keine Einstellungen gefunden.

    Gruß
    Ron

     
  • m.prestel

    m.prestel - 2021-09-16

    Hallo Ron,
    ich kenne das "Problem" nur, wenn du die Webvisu bereits geöffnet hast, dann Overlay aktivierst, aber nicht die Webvisu mit F5 neu lädst.

    Hättest du bitte einen Projekt mit Steps to repeat für mich?

    Danke!

    LG
    Marcel

     

Log in to post a comment.