Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

MQTT (Stefan Dreyer) - Errors after libraries were added

skalakope
2021-08-06
2021-08-16
  • skalakope

    skalakope - 2021-08-06

    Dear All,

    I have tried to added different libraries in order to able use MQTT in my CodeSys project, but during it,
    errors happened. (please find err.png by attachment)

    Nect to the name of a necessary library (Zigbee2MQTT), I can see an "i" in a blue circle, thats all.

    The error description is: "C0180: Ambiguous namespace 'STANDARD' defined by library 'Standard', 3.5.17.0 (System)'
    All of the other description is the same, only the version number is different.

    How can I solve this problem?

    Thank You in advance!

     
  • h-hermsen

    h-hermsen - 2021-08-06

    My guess is that you added multiple instances of the Standard Lib with different versions in your project, probably in seperate library managers(?), but without a projectarchive it's guessing. Can you post your .projectarchive?

     
  • skalakope

    skalakope - 2021-08-16

    Dear Hermsen!

    Sorry for the late response, I was on holiday.
    Please find the project by attachment, but I have done it at the first time, so I was not sure, what to do.
    What I've made is: File->Project archive->save archive...

    If You have any other question, please let me know!

    Thank You in advance!

     
  • skalakope

    skalakope - 2021-08-16

    So, what I have tried just now, to remove the libraries from Tools->Library repository...
    Only the latest version was in my library. During the code generation the old version of Standard were missed, so I had to download them again.
    After that the error above happened again.

     
  • h-hermsen

    h-hermsen - 2021-08-16

    Okay I think understand what is going on. I think there are several different standard libs referenced in the MQTT related Stefan Dreyer libs. To solve this, you need to fix the stefan dreyer related libs (fix+add) after you have deleted the current ones.

    1) First of, remove all MQTT and OSCAT related libraries from the Library Manager.
    2) Update the all related MQTT libs of Stefan Dreyer by downloading the latest ones from his github. Be sure to use the latest references. In general you can achieve this to just update all references to the latest if you open the library.
    3) Now insert these new libraries with latest references into your project.
    4) problem solved

     
  • skalakope

    skalakope - 2021-08-16

    OK, I will do it, and let You know the result.

    My plan is based on your post is:
    1. Remove the libraries as You mentined
    2. try to build -> it should be OK
    3. Install new libraries one by one
    4. try to build after a library was added -> check which one causes error
    5. If no errorat all -> OK

    I will be back.

    Thank You for the help!

     
  • skalakope

    skalakope - 2021-08-16
     

    Last edit: skalakope 2021-08-16
  • skalakope

    skalakope - 2021-08-16

    Dear Hermsen!

    I remove the OSCAT basic library, and after that I could build w/o error, so I have downloaded the latest version of it (3.3.4.0), and just with this update I could build the code.
    I think, it caused the problem.
    Please let me to ask, how can I recognize which library causes problem?
    Is there any offocial or professional way to recignize it, or the only thing, what I can do is remove and build one by one?

    I am newbie, so I am not familiar with libraries.

    So, I am grateful for the help!

    Best wishes!

     
    πŸ‘
    1

Log in to post a comment.