CNCprepro2Dir multiple CNC possible

2011-10-17
2011-10-25
  • martinus1971

    martinus1971 - 2011-10-17

    Hello to you all,

    As a noob i'm working with codesys V3 and i like what i am seeing.

    Now i'm trying the CNCprepro2Dir and its working fine.... i would like to know if its possible to chose between different cnc program's(read drawings) from your visualisation. For instance when i choose picture 1 the NCdecoder will decode drawing 1 and when i choose picture 2 the NCdecoder will decode drawing 2.

    I can change the input NCprgname on the NCdecoder function block with codesys, but i want it to be canged by my visualisations.

    Does annyone has experience with this an would he like to share this

    Allready thanks for the help

    Martinus

     
  • martinus1971

    martinus1971 - 2011-10-18

    Nobody

     
  • timvh

    timvh - 2011-10-18

    If I understand you correctly you want to make the ncprog selectable.
    Just create a new variable of the type SMC_CNC_REF.
    In your visualization create some buttons with an input to write the desired ncprog to the variable SMC_CNC_REF.
    This variable is the input of your FB.

     
  • martinus1971

    martinus1971 - 2011-10-20

    Hello TimvH,

    Sorry for the late reaction..... to much work in to litle time

    That's excacly what i mean .... i hope i have the time to try it out the comming weekend

    i'l keep you posted

    Thanks for your help so far

    Martinus

     
  • martinus1971

    martinus1971 - 2011-10-25

    Hello TimvH,

    i have tried it this weekend, unfortunaly did not get it to work.

    Made a new Variable of the type smc_cnc_ref and made a button in my visual.
    When the button is pressed a bool is made true and i write a variable to my new made variable SMC_CNC_ref witch
    is the input for NCprog on the function NCdecoder.

    What am i doing wrong?

    Martinus

     
  • martinus1971

    martinus1971 - 2011-10-25

    Hi there,

    I found the problem

    The boolean witch i used to load the cnc data in the SMC_CNC_ref was left on true, this way it kept on loading
    and the block never became ready to use.

    Fixed it and now its working

    Thanks for helping

    greets

    martinus

     

Log in to post a comment.