How could I reinstall the CoDeSys 3.5?

oven
2021-01-04
2021-01-05
  • oven

    oven - 2021-01-04

    I tried clean a lot the Register of Windows 10 pro (64) manually, but still get that message.

    I deleted all folders Codesys and Codemeter in Program Files(x86), Program Data, Users\USERNAME\appdata - there is nothing, Users\USERNAME\AppData\Roaming\CODESYS and checked Users\USERNAME\AppData\Local - there is nothing.

    I used ccleaner a tens times also.

    Tell me please, where else could be placed that mentioned config file for I delete it?!

     

    Last edit: oven 2021-01-04
  • oven

    oven - 2021-01-05

    Yes, You are right! As far as I deleted 'HKLM\Software\Classes\Installer\Products\DFA7A28E8FE89B44F9D5577066BC12C7\SourceList' branch, the CoDeSys installation was succesfull! Thanks a lot! The question is closed now.

    (Of cource the CoDeSys vendor should pay in attention the case of broken installation else me and others had a lost time a lot.)

     
    πŸ‘
    1

    Last edit: oven 2021-01-05
  • Morberis

    Morberis - 2021-01-04

    When I look at my install this is where I see Codesys folders
    -The location you installed it
    -if the x64 version in program files
    -if the x86 version in program file(x86)
    -in program data, C:\ProgramData\
    -in users, C:\Users\USERNAME
    -in appdata, C:\Users\USERNAME\AppData\Roaming\CODESYS and C:\Users\USERNAME\AppData\Local

     
  • oven

    oven - 2021-01-04

    Thanks Morberis! I deleted files in C:\Users\USERNAME\AppData\Roaming\CODESYS (and changed my question). But still get the same message.

     
  • Morberis

    Morberis - 2021-01-04

    Hmmm. It seems that it's a registry error that leads to something like this, so deleting folders probably won't help. Just looking at people who have had a similar message for other programs, this is what I found.

    You can enable logging for the installer to see where it's chocking. Then you can manually navigate to that registry and delete it.

    The windows installer cleanup utility might be able to help. But it does look old.

    I'll be honest, I've never heard anything good about CCleaner. Either it does nothing that you'll ever notice, messes something up, or doesn't fix the registry problem. But if you've had good experience with it, thumbs up.

     

    Last edit: Morberis 2021-01-04
  • oven

    oven - 2021-01-05

    There is only log file remained after closing modal window:

    === Verbose logging started: 05-Jan-21  11:50:16  Build type: SHIP UNICODE 5.00.10011.00  Calling process: C:\WINDOWS\SysWOW64\MSIEXEC.EXE ===
    MSI (c) (B8:88) [11:50:16:574]: Font created.  Charset: Req=0, Ret=0, Font: Req=, Ret=Arial
    
    MSI (c) (B8:88) [11:50:16:574]: Font created.  Charset: Req=0, Ret=0, Font: Req=, Ret=Arial
    
    MSI (c) (B8:E4) [11:50:16:605]: Resetting cached policy values
    MSI (c) (B8:E4) [11:50:16:605]: Machine policy value 'Debug' is 0
    MSI (c) (B8:E4) [11:50:16:605]: ******* RunEngine:
               ******* Product: C:\Users\user\AppData\Local\Temp\{C283CD13-588A-4DB1-B7FC-6082942490AB}\CODESYS 3.5.14.30.msi
               ******* Action: 
               ******* CommandLine: **********
    MSI (c) (B8:E4) [11:50:16:605]: Machine policy value 'DisableUserInstalls' is 0
    MSI (c) (B8:E4) [11:50:16:683]: Warning: Local cached package 'C:\WINDOWS\Installer\c9049d4.msi' is missing.
    MSI (c) (B8:E4) [11:50:16:683]: Unexpected or missing value (name: 'PackageName', value: '') in key 'HKLM\Software\Classes\Installer\Products\DFA7A28E8FE89B44F9D5577066BC12C7\SourceList'
    
    MSI (c) (B8:E4) [11:50:16:683]: MainEngineThread is returning 1610
    === Verbose logging stopped: 05-Jan-21  11:50:16 ===
    

    I think I should close the question. It is too rare problem I had.
    At least, thanks You that I had knew about verbose logging. I shall use it.
    Wishes!

     
    • Morberis

      Morberis - 2021-01-05

      I actually remember reading about someone else having an issue like this sometime in the past so I don't think it's too rare of a problem for anything.

      Looking at your post I've bolded and qouted below what looks to be the registery you have to delete, which maybe you figured out.

      MSI (c) (B8:E4) [11:50:16:683]: Unexpected or missing value (name: 'PackageName', value: '') in key 'HKLM\Software\Classes\Installer\Products\DFA7A28E8FE89B44F9D5577066BC12C7\SourceList'

      In case you've never done any work with registeries before here is a link to how to do so in windows 10.

       

Log in to post a comment.