Wago PFC200 (750-8202) RS-232

2019-01-28
2019-01-29
  • demedeirosa

    demedeirosa - 2019-01-28

    Hi All,

    I am trying to use RS-232 on the PFC200. I am having issues where the output is not the +/-12V that is shown in the documentation. It appears that the output is standard TTL and is not inverted as it should be. According to Wago, the port should auto configure between RS232 and RS485. I do not see that happening. Is there a parameter in the library that will configure the output?

    I have come across posts here stating that the 750-652 RS232 card is not supported in CodeSYS V3. Has this changed at all? The on board RS232 does not appear to be working correctly.

    Anyone have any info?

    Thanks

     
  • eschwellinger

    eschwellinger - 2019-01-29

    Hi,

    in general on PFC's you could change the serial by the PLC shell commands(that is the way you need to set it up once):
    serialmode rs232
    There is a known bug which is fixed with 3.5Sp14PPatch1 (release 19th February 2019) if you are using 2th generation PFC's and
    with Firmware 11.

    BR
    Edwin

    IMG: PFC200_serialMode.png

     
  • demedeirosa

    demedeirosa - 2019-01-29

    Thank you! For the shell commands, would that be done via the service port/cable on the pfc200? Or is there a different way to access the shell?

    Thank you

     
  • demedeirosa

    demedeirosa - 2019-01-29

    Sorry! I didn't see the attachment until I replied on mobile! Thanks!

     

Log in to post a comment.