espenbo - 2021-11-23

How sombody used the Function FbHttps_get from e!cockpit wagoAppHTTP.
I'm trying to get data from a webpage, but I can't get it to read from a page.
I have Internett aksess from the PLS. I can ping google.
Does sombody have an example I can look at?

I tried to makee a DUT

TYPE DUT_Norpolbuffer:
bData: BYTE;
sData: STRING;
dwData: DWORD;
charData: CHAR;

The program

FbHTTPs_Get_1 : FbHTTPs_Get;
// INput
sURI : STRING(1023):='';
eAuthentication : eAuthentication :=1; 
array_pRxBufferUNIO : ARRAY[1..255] OF DUT_Norpolbuffer;
udiRxBufferSize : UDINT :=1024; // receive buffer size
tTimeout : TIME; 
xTrigger : BOOL; // perform a request
xBusy : BOOL; // job in progress
xError : BOOL; // job finished with error
oStatus : FbResult; // WagoSysErrorBase // detailed status information
udiRxNBytes : UDINT; // Number of Bytes, that have been received by the Get-command
uiStart : UINT := 1 ;
uiStop : UINT := 500;
tekst1 : STRING(2000);
Fb_JSON_ParseAndModify_0 : Fb_JSON_ParseAndModify;
xTriggerJSON : BOOL;
oStatusJSON : WagoAppJSON.WagoSysErrorBase.FbResult;
xErrorJSON : BOOL;
diTokenJSON : DINT;

Program se Attachments

First signs from the website:
{"data": {"Rows": [{"Columns":

As I understand it, I get out DWORD. And it gets converted to BYTE, CHAR but not STRING.
Now I tried and take this array into JSON_function blocks it just complains that it is not STRING.
Do anybody have any tips?