tmarion - 2019-01-16

Currently have an Allen Bradley 1734-AENT (CIP Ethernet) Module, with 2 points of IO. In the first slot is a 1734-IB4 (4 point Input), and in the second slot is a 1734-OB8 (8 Point Output). The point IO is configured and happy. I have downloaded Codesys to run on my Raspberry Pi 3 b+. The code runs on my PI, I have just a simple program right now. A flash timer and based on if I have input 0 or 1 from my Input card it adjust the flash time.

I am using my computer thru a Hirschmann spider 5Tx Ethernet switch and I can ping everything. Everything independently seems to be working fine.

I am very new to Codesys, but have been using AB for some time. When I download to the RPi and put it in run mode everything in my devices is green. I am using the Ethernet_IP_Scanner; followed by the _1734_AENT_EtherNetIP_Adapter provided by Codesys. This starts out with a Red Triangle, indicating error, but after a few seconds it also turns green. I have mapped my IO and I still get nothing back from the Point IO module.

I have a feeling I dont have something quite right in my configuration (although Codesys isn't flaging it as bad), which is preventing me from getting back my IO to the codesys platform via Ehternet. Has anyone worked with one of these before and can anyone shed some light as to what I might have configured wrong. I have attached my connection. Any and all insight is greatly appreciated!!

IMG: Connection.PNG