Connection to device closed

  • mozed - 2023-08-23


    I am using an OpusA3 with version 3.5 SP17 Patch 3 as part of a project. I had no real problem before I encountered a problem that blocked me.
    The detection of the OpusA3 from Codesys is done correctly. The gateway is well configured and if I ping the gateway or the OpusA3 I receive the response correctly.
    The problem is that when I try to connect, the Opus screen freezes and a few moments later Codesys displays an error message ("connection to device closed").
    I tried to change PC, to update the runtime, to change OpusA3 but the problem remains the same. I'm a little lost knowing that before it worked without problem.
    I went back to a previous version of the project (where it worked correctly) but the message still appears.
    Do you have any clues to solve the problem?


  • eschwellinger

    eschwellinger - 2023-08-24

    is there a way to check the plclog on Opus A3 by using cmd line under Linux? This log is what you need to check for the disconnection problem

  • mozed - 2023-08-25

    i found this error in /opt/CoDeSysControl/Files


    Last edit: mozed 2023-08-25

Log in to post a comment.