Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

EL2911

2020-10-12
2022-10-07
  • yannickasselin

    yannickasselin - 2020-10-12

    Hello,
    I am planning to use Codesys Safety with Beckhoff hardware. I would like to know if the Beckhoff EL2911 is supported as the TwinSAFE Logic controller?

    On the Codesys store, it is said that the EL6900 and EL6910 are supported. Are the new TwinSAFE Logic terminals EL1918, EL2911 and EL2912 also supported?

    Thank you.

     
  • yannickasselin

    yannickasselin - 2020-10-21

    Anyone? I would like to know if supported before buying...

    Thank you

     
  • eschwellinger

    eschwellinger - 2020-10-21

    hi,
    EL1918 with next version ( release will be ~ mid December)
    For EL2911 and EL2912 I have not really a release date only th info that it will come.

     
  • yannickasselin

    yannickasselin - 2020-10-21

    Thank you very much.

    Just 1 more question, does the "Safety for EtherCat" work with the Raspberry Pi? (Of course I mean if I buy the license)

    Thank you.

     
  • eschwellinger

    eschwellinger - 2020-10-21

    sure with any CODESYS SL runtime device which supports EtherCAT (... all of them)

     
  • yannickasselin

    yannickasselin - 2021-04-20

    I have to order my safety hardware. I would like to know if the EL1918 is actually supported. The description of the safety SL does not state that it is supported. Thank you.

     
  • eschwellinger

    eschwellinger - 2021-04-20

    Supported only for io's not for the embedded safety PLC at the moment.

     
  • yannickasselin

    yannickasselin - 2021-04-20

    Thank you. I think I will order an EL1918 but I will use an EL6900 that I already have until it is fully supported.

    Thank you.

     
  • yannickasselin

    yannickasselin - 2021-04-20

    Are EL2911 and EL2912 also supported for IOs?

     
  • eschwellinger

    eschwellinger - 2021-04-22

    oh it turned out that I was wrong with EL1918 on EL6900 as io.
    See documentation of EL1918 -> only possible to use with EL6910 or EL1960
    "Operating Instructions for EL1918", V1.2.0, page 40
    Still no feedback on EL2911 and EL2912 but I fear it is the same.

     

    Last edit: eschwellinger 2021-04-22
  • yannickasselin

    yannickasselin - 2021-04-22

    Ooops.... I already ordered everything.

    When will the embedded safety PLC of the EL1918 will be supported?

    Thank you

     
  • yannickasselin

    yannickasselin - 2021-06-02

    Any idea of when this will be supported?

     
  • yannickasselin

    yannickasselin - 2022-04-10

    Hello,

    While watching the "CODESYS Feature Briefing 2022 – Part II" on youtube I saw that the EL1918, EL2911 and EL2912 logic should be supported in SP18. But the safety package in the store still does not support them. Will there be a new version of the safety package coming out soon?

     
  • eschwellinger

    eschwellinger - 2022-04-11

    Should be possible with 4.3.0.0 Version

     

    Last edit: eschwellinger 2022-04-11
  • yannickasselin

    yannickasselin - 2022-04-11

    I just tested it and it works.

    Thanks.

     
  • yannickasselin

    yannickasselin - 2022-10-05

    EL1918 is now supposed to be supported for safe IOs and Safety Logic. I cannot figure out how to use it for both.

    When I add the EL1918 in my project, it seems to be used only for Safety logic. How can I add the safety IOs? I want to use the same EL1918 for Logic and IOs.

    Thank you.

     
  • yannickasselin

    yannickasselin - 2022-10-05

    Ok. I figured it out. You need to manually add a Logical Device (EL 1918 FSoE Message) in Logical I/Os. And then link the FSOE_Slot to it in Module I/O Mapping.

     
  • yannickasselin

    yannickasselin - 2022-10-05

    I cannot download the safety project. It is giving me this error:
    the RUN-signal has to be active in the Group cfg data at word-offset 0x23

     
  • alsa-ctr-tech

    alsa-ctr-tech - 2022-10-05

    Hi yannick or to anyone who can help, I have a similar issue as you had on one of your previous post. I use a EL1918 as my safety PLC and for some safe inputs with a EL2904 for my safety outputs, I have added the IOs of both of these devices in my "Logical I/Os" however the field "Physical I/O mapping" is greyed out and blank I'd like to know how you manage to link them. Should I be able to complete this linking manually ?

     

    Last edit: alsa-ctr-tech 2022-10-05
    • yannickasselin

      yannickasselin - 2022-10-06

      It is always greyed out in "Logical I/Os". You need to link it in the FSOE_Slot.

       
  • alsa-ctr-tech

    alsa-ctr-tech - 2022-10-07

    So, in the end there's a way to go around the issue I had, I was adding the devices by scanning the EtherCAT Network, the ESI files used after the scan weren't the right ones, I was then performing an "update device" in order to use the ESI files that were suiting my use. Well that way the SafetyApplication wasn't able to detect the FSOE IOs in my network. Deleting all of the devices integrating an FSOE component and then adding them back "manually" did the trick and the safety application was able to complete the IO mapping with FSoE IOs by itself.

     

Log in to post a comment.