OPC UA Client unable to connect to CeDeSys OPC UA Server but able to connect to other OPC UA Server

  • HOT

    HOT - 2018-10-25

    i have a problem with the CodeSys OPC UA Server running on a Raspberry Pi.
    I try to build up a connection between an OPC Client (Siemens PLM Software Process Simulate) and the CoDeSys OPC UA Server running on a Raspberry Pi.
    Unfortunately i have no success building up the connection.
    The Client can connect to the Unified Automation OPC UA Server without any problems. When i try to build up the connection to the CodeSys OPC UA Server i get a message that the client is not able to retrieve the endpoints on the server but is able to validate the connection

    Security mode is none and because of the fact that the client can connect to the UA OPC Server without problems i guess that there must be some differences in the server configuration that leads to the error.

    I'm also able to use UA Expert OPC Client to connect to both OPC UA Servers (UA Server and CodeSys Server)

    In the attached picture i just tried to figure out what differences are visible in the UA Expert connection to both servers. At a first view there a differences in the Root folder:

                  UA Server   vs  CodeSys Server:

    DisplayName: "en" vs "en-Us"
    WriteMask: 0 vs BadattributeIdInvalid (0x80350000)
    UserWriteMask: 0 vs BadattributeIdInvalid (0x80350000)

    For the error 0x8035000 i just found this


    Any hint to build up a connection are welcome!

    Thank you


    IMG: UA_Expert_compare_servers.png

  • HOT

    HOT - 2018-10-30

    as an update to my question. I'm not able to connect the Siemens Client to the local Codesys OPC UA Server when i run a demo project on the local Codess Control Win.
    Connection between UA Expert and the local OPC UA Server in the demo project is running fine.

    Are there any more options to configure the OPC UA Server within Codesys (change the name, the encoding, generate a more detailed log to show the requests from a client) that i haven't found yet?

    Kind regards



Log in to post a comment.