Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Could not open library CmpIoMgr Interfaces

  • dhumphries

    dhumphries - 2021-10-13

    When I create a new project using the standard project template I am greeted with a library manager error stating:

    Could not open library 'CmpIoMgr Interfaces, * (System)'. (Reason: The library 'CmpIoMgr Interfaces, * (System)' has not been installed to the system.)

    This wasn't a problem a couple months ago when I did training, I created dozens of new projects this way and never had any problems. I've tried clicking on the ... box and choosing download missing libraries, but the resulting dialog box is empty.

    I have installed some modules in the codesys installer since I last tried to create a new program, would installing additional modules remove some libraries previously installed? This library doesn't seem to be in the library repository, is there any way to get more information about the library so I can add it to the repository?

  • mr337

    mr337 - 2021-12-06

    I too am running into something similar. The issue is the library has been installed. In this case I'm running into issues with CANbusDevice and IoDrvJ1939.

    Funny enough the libraries are installed in C:\ProgramData\CODESYS\Managed Libraries\3S - Smart Software Solutions GmbH. I can see them but Codesys refuses to find them :S

  • dhumphries

    dhumphries - 2021-12-08

    Based on an hour or so of searching, it seems like questions about missing or broken libraries are never answered here. I did reach out to Codesys directly and got a suggestion to try re-installing Codesys. Their reasoning was that the CmpIoMgr Interfaces library is part of the Codesys installation, if it's not working the library must have been corrupted and can only be restored with a re-install. I haven't tried re-installing because I have a project where all the needed libraries are working, I don't remember what I had to do to get the libraries I needed working, but it was a minor struggle, I don't want to break the libraries that are working for that project.


    Last edit: dhumphries 2021-12-08

Log in to post a comment.