Unable to control Delta R1-EC5621

  • hantin89

    hantin89 - 2016-10-07


    i have setup codesys softmotion to link delta ethercat motion module card Delta R1-EC5621. It can initialize CiA402 connection until op mode with steady green status light on the module.

    But when i trying to use online commissioning mode it only show power on state and servo on once then it will not have any response even trying to power off or jog it. It didn't show any error message. I also tried with DC sync time 1000us and 2000us but not working also.

    Below screenshot is my connection, ignore the red triangle as i able to initialize it when i tried using codesys softmotion ver now.

    attachment is the device file of the remote io.

    Besides, i tried testing with the same remote io and device file using twincat 2. It can be servo on and off and sending out pulse to drive servo motor.

    I found that the process data setting is different in twincat and codesys as below image using same device file.

    Please help any setting i need to set to link with this Delta R1-EC5621 ?

    IMG: Screenshot_5.jpg

    IMG: Screenshot_6.jpg

    Delta R1 EC55xx.xml [11.4 KiB]

    Delta R1 ECx62x.rar [9.73 KiB]

  • JamesPeng-TW

    JamesPeng-TW - 2018-06-29


    The problem is been almost 2 years here. Did you get the problem solved?
    I have the same issue with you.



Log in to post a comment.