Cannot start config mode + position data from AKD

Motion
cerminek
2018-11-14
2018-11-15
  • cerminek

    cerminek - 2018-11-14

    Hello all,

    I've just tried to start a config mode and it did not start due to errors, see bellow. Online works properly, drives can be controlled and they are moving. When new project were made with the same EtherCat devices, config mode can be started... Does anyone knows why?

     
    [ERROR]         PROJECT: HiddenOnlineConfigModeApp [Device: PLC Logic]: C0077:  Unknown type: 'SM3_Basic.SMC_Commissioning_SM_Drive_ETC_Kollmorgen_AKD'
    [ERROR]         PROJECT: C0035:  Program name, function or function block instance expected instead of '_Comm_SM_Drive_ETC_Kollmorgen_AKD.AfterReadInputs'
    [ERROR]         PROJECT: C0077:  Unknown type: 'SM3_Basic.SMC_Commissioning_SM_Drive_ETC_Kollmorgen_AKD'
    

    Second issue I have is position data from Kollmorgen AKD servodrive. There is no mechanical units set in servodriver, only Counts 16bit. The servo has SFD (2^24 increments) encoder. BUT the position values in Kollmorgen Workbench does not match to any position value in CoDeSys (scaling were disabled). Screens are in attachment...

    AKD position.pdf [286.34 KiB]

     
  • cerminek

    cerminek - 2018-11-15

    So small update. There is nothing about it in documentation BUT Kollmorgen AKD sends its position in 20bit resolution, in Kollmorgen WorkBench it is in 16bit value 'or 24bit as SFD encoder).

     

Log in to post a comment.