Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Codesys Control shutdown

  • mm0200 - 2023-04-26


    I have problem with Codesys control shutdown. The text of the device SOS report is attached. The device (raspbian with support for Codesys) works correctly for a while and later it is no longer possible to connect to the device through the Codesys environment.

    Thanks for any suggestions.

  • mossi92 - 2023-05-04


    I have the same problem running codesys 4.7 on a revolution pi connect S with buster.
    did you find a solution?

  • ivanmaltar - 2023-05-15


    I have also came across this problem using the Revolution Pi Connect S controllers. Has anyone been able to find a solution or any workaround to this problem?

  • mqi2r

    mqi2r - 2023-05-22

    I too have the same issue. After 1 or 2 days Codesys appears to lock up or freeze.

    I was able to SSH into the RevPi but no matter what I did I could not stop/kill the codesyscontrol.bin process. I had to reboot the device and it was operational again.

    Codesys Control for Raspberry Pi 4.5
    CDS 3.5.17 Patch 4
    RevPi Bridge Library

  • shanepratt - 2023-06-14

    This may be due to versioning issue - RevPi states the bridge version is used for Codesys Raspberry Pi Control version and the bridge version is used for Codesys Pi Control version I would try contacting RevPi to see if there is any known issues with this mismatch in versions or try updating the bridge or Codesys Pi Control versions. Let us know if this helps.

    • mqi2r

      mqi2r - 2023-06-15

      Hi, yes I am aware these are mismatched versions to what Kunbus recommend. We have also tried the latest official combination of software versions with still the same issue.

      Software Combination 1
      Codesys Development System 3.5.17 SP4
      Codesys Control for Raspberry Pi
      * Revolution Pi Bridge driver

      Software Combination 2
      Codesys Development System 3.5.18 SP4
      Codesys Control for Raspberry Pi
      * Revolution Pi Bridge driver

      From what we can tell, the issue for us manifests on systems with a RevPi Connect+ and a MIO module in the chassis. All our other systems without MIO's have not exibited this issue.

      I've been in contact with Kunbus and they have requested I try running the following versions, even though their documentation currently still states the versions under combination 2 above.

      Suggested Combination from Kunbus
      Codesys Development System
      Codesys Control for Raspberry Pi
      * Revolution Pi Bridge driver

      This combination has been working fine on our test bench for the last few days, our freezing issue has appeared anytime from a day later to 14 days later so still some time before we can assume it is resolved.

      • hwopereis - 2024-03-25

        Hi, I'm experiencing this problem as well. Did the suggested combination resolve your issues in the end? If not, I can stop my efforts rolling back to these versions.

        I'm trying to get CC for RPi installed on the device, but I can't find it after installing it through the packet manager.

  • ivanmaltar - 2024-03-25

    Hello, the problem was that the Codesys control was not compatible with S versions of the RevPi controller because of the becuase of the Compute Module 4S. For those controllers, version must be used.


Log in to post a comment.