Welcome to our new forum
All users of the legacy CODESYS Forums, please create a new account at account.codesys.com. But make sure to use the same E-Mail address as in the old Forum. Then your posts will be matched. Close

Profinet Device keeps abort connection with AR alarm.ind(err)

asivakov
2022-02-05
2022-06-08
  • asivakov

    asivakov - 2022-02-05

    Hello!

    Got Another issue...
    I was able to use my early method of connection to profinet slave ( https://forge.codesys.com/forge/talk/Runtime/thread/c7f677ad27/#86e2 ) and everything was fine until I used windows hyper-v server (almost same as proxmox virtual environment on ubuntu server, but on windows server). For some reason proxmox hangs up on rebooting and have very long start on this mini-pc, so it cannot be used. After virtual plc starts, all the connected devices after 20 seconds keep sending errors and reconnect:

    CF81FD0B
    Connection aborted: AR alarm.ind(err)
    

    Google don't know why this error occurs and what it means, also nothing useful on forge can be found.
    Yet, same project, Same virtual machine (on virtual box with copying of hdd file), same devices, except pc, and everything works perfectly!
    Help me please, it is very important for me.

     

    Last edit: asivakov 2022-02-05
  • ivan

    ivan - 2022-05-29

    Have you sloved this problem?

     
  • asivakov

    asivakov - 2022-06-08

    Hi.

    Not shore, but looks like problem was on Ethernet switch through which connection was. Actually ping was jumping on 300ms and more. So problem was solved by connecting straight on Ethernet port it'self.

    Got lesson to check your periphery =)

     

Log in to post a comment.